PDA

View Full Version : Error expanding Grid Part template: convert_number


ABC123

josevelez
04-29-2013, 12:53 PM
I am getting this error all of the sudden after updating to the latest V12 patch. Nothing has changed with the grid or the query behind the grid. I've check and both my server and developer are using 1381-4118.

Error expanding Grid Part template: convert_number(tbl.data("surf_csg_toc")): Too few parameters

Anyone else seen this come up?

Clipper87
04-29-2013, 04:43 PM
Try making the grid 'dirty' & save+publish it again.

josevelez
04-29-2013, 04:45 PM
This seems to be happing for one particular field and only when the field is empty. All of my other records come back fine with that particular field has a value. I'm scratching my head... is this a bug?

josevelez
04-29-2013, 04:49 PM
Frank,

Just tried, no luck. :( I'm going back to check my grid. Stay tuned.

josevelez
04-29-2013, 05:22 PM
Weird.... I reinstalled the full V12 download (which is now 1381-4118) for both the server and the developer and it works again. I even checked while I was re-publishing my components and it worked.

rjackson@arach.net.au
12-09-2014, 08:39 PM
I grappled with this error in v11 for some time and it nearly sent me loopy as I kept thinking it was something I'd done. Only some records were affected!

The fix:
Make sure the Alpha app server version matches your dev environment version, regardless whether you are using v11 or 12.

And importantly:
If you are running v11 and v12 on your hosting server and on your dev machine (like me) make sure your v11s are the same build and your v12s are the same build. I went crazy when a v11 app kept throwing this error even though v11 builds were identical, then after hours of head scratching (and some choice words) it occurred to me that I'd previously updated v12 on my dev machine and perhaps v12 shares some bits with v11 so I updated my v12 app server to match my dev machine and magically the v11 problem went away.

Suffice to say I never want to go through that again, especially when a live app is suffering!

Hope this helps anyone who comes up against this.