PDA

View Full Version : File Upload Action Script Not Honoring File Type Restrictions


ABC123

iRadiate
06-29-2013, 01:33 PM
I'm using the File Upload action javascript feature to upload files from a dialog component.
I've set the Allowed File Extensions property to .pdf but this is not being honored and I am able to upload files of any extension.
It seems to allow any file upload regardless of what I put in the allowed extensions property.

36121

Is anyone else using this and can confirm the behaviour?

Thanks,
Stephen

Clipper87
06-29-2013, 05:29 PM
Ran a quick test, does indeed not seem to honor anything you put in the allowed file extensions property. Worse it does not seem to upload anything either ?

iRadiate
06-29-2013, 05:34 PM
Ran a quick test, does indeed not seem to honor anything you put in the allowed file extensions property. Worse it does not seem to upload anything either ?

Thanks for the reply Frank, I will drop them a bugrep on Tuesday (since Monday is a holiday here ... Happy Birthday Canada :grin:)

The upload works okay for me but I can't have users uploading .exe's and the like.

By the way, I had to figure out how to use the Upload/Download component ... is there no video on this?

Stephen

kiwibruce
06-29-2013, 08:04 PM
Hi Steven,


By the way, I had to figure out how to use the Upload/Download component ... is there no video on this?

Help|Video Finder
Search 'Upload'
Returns
UX_V12--8 Image upload
UX_V12--9 Image upload to an Image Control that is Not Data Bound
UX_V12--45 Image upload - Creating Thumbnails of the uploaded Image
V10FP7 Image upload
V10FP9 File/Image Download
UXM_V12--6 Accessing the Camera

Hope these help

Happy Canada Day
Bruce (ex Vancouverite)

iRadiate
06-29-2013, 08:07 PM
Bruce,

Thanks for the tip, why didn't I think of that.
I was trying to muddle around the YouTube videos here instead .. http://www.youtube.com/user/AlphaSoftwareInc/videos

Stephen

kiwibruce
06-29-2013, 08:33 PM
Hi Stephen,

The video finder is my first port of call these days.

B

iRadiate
07-11-2013, 12:53 PM
This was a confirmed bug and will be fixed in the next update.