View Full Version : UX Dialog is buggy


07-15-2013, 09:46 AM
I've already discussed the issue that calling a UX dialog from a grid without caching the UX dialog causes issues with the Submit and Reset buttons failing to work after the first time the UX dialog is opened. Now I've discovered that if you leave caching turned on and have a linked grid in the UX component or you have a list in the UX component based on a custom Xbasic function that there is no way to get them to refresh so they always show the data from the first record you open the UX component. I've tried adding code to the OnDialogSynchronize event in the UX component to no avail and I've even placed a button that calls for a refresh of the list directly on the UX component and neither work. Now, if you turn off caching the list and/or grids display the proper data but you're back to not being able to submit data changes after the first call.

I'm getting a little frustrated at doing the quality control tests for Alpha and spending as much time developing test case databases to submit as bug reports as I am doing development work.

To see what I'm talking about link the attached database to your Northwind database, open the DefaultGrid and search for Customer = A. In the grid click the Edit button to open the UX dialog, go to the linked grid tab and select Show Grid. You'll see the correct data. Now exit the UX dialog and Edit another customer. The UX dialog shows the new customer but still shows data for the previous customer in the linked grid. <sigh>

07-15-2013, 09:54 AM
Okay, I found out what has to happen to get the grid to refresh. I had to check the Live Link and give the grid an explicit alias. That doesn't solve the issue with lists based on custom Xbasic (unless of course I'm overlooking another setting somewhere...always a possibility with the myriad of settings available.)

07-15-2013, 04:54 PM
How did you go about turning caching ob and off ? I vaguely remember something similar when using a ui tabbed control and placing some html on the a5w page that ultimately corrected the situation.

07-15-2013, 05:15 PM
You turn the cache on and off for the component in the button that opens the component. When you go to component properties on the button that is calling you have a check box that says "Use cached component".