View Full Version : Runtime not showing status or start form


09-28-2013, 09:35 AM
I have written an automated nightly update that I run on the server. The process converts several thousand records and prepares them for upload to a remote web server. In the upload.adb I have set an autoexec that opens a form which calls in its timer event the two functions which update the records. I also have a statusbar.show() command. When I open this in the full development system I see the form and the status bar gives me feedback as to where in the process I am. When I open this in the runtime all I get is a blank screen, no menus, no status bar, no form but the routine runs to completion and then the application closes (I have an a5.close() at the end of the routines). I would like for my users to be able to see that the process is running in case they need to do the update manually.

I've tried opening just the upload.adb and I've tried setting a shortcut to "C:\Program Files (x86)\a5V12runtime\alpha5.exe" "L:\WEBUPLOAD\upload.adb".

Both run the same way. Further I see the same behavior when I open the Alpha 5 runtime and then load the upload.adb from Recent Workspaces.

If I turn off the Autoexec and open the form manually I see the form and all the status updates.

Again, none of this happens if I open the workspace in the full development version. Any thoughts?

09-28-2013, 10:04 AM
Okay, never mind. For some strange reason my updated versions of the database were not getting written to the server. I just wiped everything and copied the whole kit and kaboodle over again and all is well. I hate weird stuff! :thinking: