View Full Version : Memory Corrupt - Terminate Operation


12-13-2014, 10:55 PM
I copied the Progressive Find script from the Alpha Sports app, which is used on the Customer Information form. Ther wasn't much to change, the table name and switched the Company field name to Address in the appropriate places. There also was a reference to customer_ID which is the actual field name. since is mine was customerid, I removed the underscore in the script to reflect mi field. Everything worked fined except for an error message. So, I switched the CustomerID back to Customer_ID and then changed my field Customerid to Customer_ID. Now, when I click the button to run the script, I get the above error message. (See Attached) I can attach the script if that will help.

12-13-2014, 11:15 PM
When I do something like that, I often have to compact the adb.
Definitely restart alpha and the computer when a memory corrupt pops up.
It seems to happen often when I am working on the dev side.

Stan Mathews
12-13-2014, 11:17 PM
Rebooted the machine and tried again? Sometimes the errors mean what they say.

12-13-2014, 11:27 PM
Hi Dave & Stan,

Those were the first things I did. Compacted, closed AA, opened and compacted again. Still happening so rebooted the machine. Still persists.

Edit: Every object I clicked on the form produced the corrupted memory error. Even clicking the 'x' in the upper right corner produced the same message. So, I deleted buttons and other objects, one at a time. When I deleted the Dropdown Browse, the problem went away. I have no idea how it became corrupted and was a bit surprised it could be corrupted. Oh well, at least it's gone.

12-14-2014, 10:29 PM
At least you discovered the source(sort of)

12-15-2014, 12:06 AM
At least you discovered the source(sort of)

LOL, It opes the doe with other questions but not going to waste my time.