PDA

View Full Version : Posting - Field Rules


ABC123

Kevin Anderson
09-10-2004, 04:21 PM
Admittedly, I've still spent little time with WAS.
That is about to change however.

I'm doing a bit more feature testing and I'm now stumped.
I will need several fields to post values to another Alpha table when records are submitted through WAS. I set the rules up in F/R and they work fine in the base V6 app, but they don't seem to fire thru WAS. My calc rules are working as expected in both places. I was sure hoping the posting rules were going to work with WAS as well. Will it be necessary to role my own posting code in xbasic on the submit action, or am I just not implementing it properly?

Sure hope it's the latter. :-)

Thanks,
Kevin

JerryBrightbill
09-10-2004, 04:42 PM
Kevin

I am sure Lenny will correct me if I am wrong, but it appears that all updates are done with xbasic, so the normal xbasic limitations in field rules apply. Therefore only the "engine level" rules will apply. I have never completely figured out exactly which rules work in all cases, so when using xbasic, I typically "roll my own" and aviod most field rules. This might be an issue with a component doing the data update, as the save operation is not exposed, but embedded in the grid code. Trapping the actual save event in a component doesn't appear possible.

Jerry

Kevin Anderson
09-10-2004, 05:05 PM
Ahhh, OK Jerry, thanks for the quick reply.
I'll be in touch with you when the time comes to roll my own posts. :-)

Kevin