PDA

View Full Version : How to publish to another PC in the LAN? (2)


ABC123

Steve Wood
09-01-2004, 12:46 PM
I don't get the publish to lan concept.

I have a server named ATDSSERVER with A5V6 WAS running and Document Root set to E:\A5Webroot. I have that directory shared so I can publish to it.

On my development client, I have the Profile set to:

Webroot: A5Webroot
Target: ATS5
Host: ATDSSERVER

1) This tries to create a directory (the msg does not specify what computer or drive it is trying to create this directory on), and fails to create the directory.

2) I've tried a bunch of variations to this (Webroot: \\atdsserver\A5Webroot. Target: "Default", etc ) and including following the instructions in the previous thread of this same name, and either cannot publish the files, or the Page To Show does not point to the correct location to launch my index.a5w file.

Lenny Forziati
09-01-2004, 12:56 PM
Steve, your webroot needs to be the full path to the webroot folder on your server. So in your case it would be

\\ATDSERVER\A5Webroot

Target further specifes a folder under the webroot in which to place the files being published. So with this set to ATS5, upon publishing it is going to try to create a new folder ATS5 in \\ATDSERVER\A5Webroot.

If this fails because of network permissions, you will recieve an error message. It sounds like this is your problem.

-Lenny

Steve Wood
09-02-2004, 12:16 PM
Sorry, still don't see the whole process working (not premissions, checked).

Given the following profile:

Webroot: \\atdsserver\A5Webroot
Target: ATS5
Host: atdsserver

"A5Webroot" is a shared directory on my server and points to E:\A5Webroot. The files properly publish to E:\A5Webroot\ATS5.

That part works fine.

When I also check the option to launch browser..., it attempts to open:

http://atdsserver//atdsserver/A5Webroot/ATS5/Index.A5w

The accurate location should be:

http://atdsserver/ATS5/

note: The WAS is set to E:\A5Webroot as the document root.

Howard G. Cornett
09-02-2004, 04:14 PM
One way that I have used that works well (for me anyway) is to use the internal IP address for the server. It might look like this:

http://192.168.1.100/ats5/index.a5w

You can get your server's IP address by going to a command prompt (start-"run-"cmd) and typing ipconfig. Then substitute your IP address for the mine (192.168.1.100) above.

Hope this helps!

Howard

Cheryl Lemire
09-03-2004, 05:21 AM
Hi Steve,

""Webroot: \\atdsserver\A5Webroot""

and

""shared directory on my server and points to E:\A5Webroot""

If the first line is accurate, this is why it is looking for the atdsserver two times.

Cheryl

Steve Wood
09-03-2004, 02:48 PM
Sorry, none of this leads me to something that works. I turned it in as a bug. I don't think you can use Publish Web Server dialog to both publish and view a page - if using the Pblish on LAN option.