PDA

View Full Version : A4V6, Win 98 & Win NT


ABC123

davej
09-10-2000, 10:43 AM
Here's a good one I've just run into. I've developed an application for a client on my office system running Win 98 and it works as it should. I installed it in the client's system (Win NT) after install the 5-user pack. Everything runs as it should. They made a CD of the application after I talked them through some
changes over the phone. Now the problem starts.

The *.DTN wouldn't load because A4 stores the path. No problem, I just had them read the desktop to me and I replicated it. When I tried to run the application on my system, I started getting errors. I can't run a saved search, I cannot get into form design and I can't rebuild an index. All of these errors appear to read the same - 'File not found or access denied (filename).UDN'.

Does anyone have any ideas that I could try short of a 4-hour drive to the client's site? I'm fairly certain that the problem has to do with the network environment, but I'm not sure.

I would greatly appreciate ANY help with this.

Thanks,

Dave

russ Boehle
09-10-2000, 01:57 PM
I sounds to me like you have absolute paths in your app that are not duplicated on the clients network. If you want to use absolute paths, which is not the best way (but I did it and now am stuck with it) make sure that you have a drive other than A:,B:, or C: on your local machine so you can map to the same drive on the NT server. Also make sure you are running from the same directory, or one named the same. By the way, I have found that desktops are not a good idea for an app. They are ok while developing but you would be better off changing the app so all dbf changes are done with a clco than w1,w2 etc. The problem with desktops is is the load order is changed or a dbf is deleted the desktop will not load properly and will have to be recreated. Its easier to just open the relevant dbf or set and the load times are almost the same.

Russ

Allen Klimeck
09-10-2000, 06:19 PM
If they copied files from the CD back to the app than the files are marked read only. In explorer have them right click the files chose properties and uncheck read-only.

davej
09-11-2000, 12:58 PM
Allen,

Thanks, you hit it on the head. I FINALLY figured that out late last night.

Dave Jampole