PDA

View Full Version : Running out of Handles


ABC123

Ryan Whaley
06-22-2000, 12:28 PM
I'm runnign Win2K and Alpha 4 v6. Whenever I run a4v6 it gives me the error:
"No more file handles left"
What is this? How can I fix this? I think it's fixed by changed the amount of memory allocated to it. Help!

Gerry Barton
06-22-2000, 03:16 PM
Hello Ryan,

You need to increse the number of file handles available to Alpha from ??? to 255 in the config.sys file located in the root directory. This has been the fix for Win95/98. I had our application running on Win 2K, and there is a "properties" tab that needs to be modified. I dont Win 2K so I cant help you there, but the files=XXX needs to be set to 255.

Hope that helps

Gerry

Ryan Whaley
06-23-2000, 06:52 AM
I've messed with the memory tab in Win 2K but still no results. Which one do I need to change? EMS? XMS? Conventional? DPMI? I made them all larger but they don't work.

Maurice Mercado
06-23-2000, 03:30 PM
Hi,Ryan. What Jerry is trying to explain is that A4 is a DOS
program which still needs some basic configuration to work under Windows. This is what you should do under W95/W98. Click start, programs, accessories and open notepad or wordpad. Click file, open. On the top of the window select drive C:. At the bottom of the window select "all files" or "all documents", find the CONFIG.SYS file and open it. Look for the "FILES=xxx" statement. If you have this statement "FILES=100" will be enough. If you don,t, just create it. If you do not have a CONFIG.SYS file in your root directory you will have to create one. In notepad or wordpad click file, new and type FILES=100 and save as CONFIG.SYS in the root directory of your C: drive. I am assuming your computer boots from C: drive. In both cases above, you will have to reboot your computer for config.sys to work. I do not know if W2k includes notepad or wordpad. In any case you can use any line editor or wordprocessor to create your CONFIG.SYS file in your root directory.
Good luck.
Maurice

Ryan Whaley
06-26-2000, 09:47 AM
Win 2K is the next iteration of Win NT, and therefore does not use config.sys. It uses registry entries and individual settings on each DOS executable for memory usage. It just doesn't seem to work no matter how much memory I allocate to it. Anyone else use Win NT or 2K with Alpha 4 that could help me out?

willy
06-26-2000, 11:26 PM
Hi Ryan

You have to change the config.nt file located in the C:WinntSystem32. Most
of file is just info but on the very bottom you will find Files=40 change it to
Files=255. This will solve the problem. Alpha 4 runs great in Windows 2000

Good Luck Willy

Ryan Whaley
06-27-2000, 06:04 AM
Thanks a lot. The solution worked nicely.

Gail Ferris
04-09-2001, 09:20 AM
Thanks Willy, I was having the same problem. I have run into it before but had forgotten how to fix it. I thought it was kinda strange as I have been using A4 on this machine for 2 months with no problem and then all of a sudden I got the no more file handles message.
Gail

John Toalson
04-09-2001, 11:44 PM
To add to the posts above, Win2k allows you to assign specific dos configuration files to each dos program. So you don’t have to use config.nt, in case it contains some configuration you don’t want to change. You can create your own configuration files specific to Alpha 4, and leave config.nt untouched. (Just in case that fits someone’s needs).

In addition, be very careful about running Alpha 4 on Win2k. I was about to upgrade our office from Win95 to Win2k until I checked out the posts concerning corruption. Apparently, it’s been confirmed by Microsoft that Alpha 4 databases will be corrupted if you reconfigure – add a field, change field length, etc. The posts were convincing enough to stop me from upgrading our office. I can’t speak from personal experience, but I won’t risk 8 years of data input to something like that.

James Hurley
04-16-2001, 06:25 AM
Have you any ideas about how to achieve the same result under Windows ME? My new box has ME instead of 98 and I keep getting the 'Out of handles' warning. How would I set the files statement for A4v6?

Thanks

Jim Hurley

James Hurley
04-16-2001, 07:10 AM
John,

Following up on my last post to ask about fixing the out of file handles problem under WindowsMe:

I was able to do it by Start, run and opening the msconfig.ini tab. There I opened the 386nh line and added 'PERVMFiles= 150'. Once I brought the system up again, it was fine. I no longer get the out of file handles error.

Jim

John Ham
05-02-2001, 01:13 PM
My issue with A4 V6 is not being able to get it to come up at all in Win2K. The dos session just blows up and goes away when I try to start the application. I've tried all the memory settings suggested on this forum and have edited the autoexec.nt and config.nt. nothing seems to work. Any ideas???

James Hurley
05-02-2001, 03:55 PM
I have never tried to bring it up on 2K. You might call Alpha to see. Maybe someone else will know how to do it.

Sorry