PDA

View Full Version : Stuck on a record


ABC123

Lane Beckes
01-30-2002, 08:44 AM
Our database is getting stuck on a record, meaning that I cannot scroll past it in browse or form mode. I can search past it by using the find command, and therefore can access records past it, but I cannot scroll past it. In the form view I see this record only once, but in browse mode it appears to have duplicated itself many times. Is this a glich anyone is familiar with? I tried maintenance, it didn't work. Can anyone help?

Lowell Wardlow
01-30-2002, 10:41 AM
Lane - have you tried looking at the browse in record order,
instead of by an index ? If it's still bad, you might try
copying or appending the .dbf file(s) only to an empty file. If you get error's you might at least find the record number(s) involved and delete the offending record.

Let us know how you come out.

Lowell

Thomas Henkel
01-31-2002, 06:42 AM
Lane,

It seems that teh record might be corrupt. If you can recreate the record, I would recommend marking the record, changing its primary key to something unoffensive, then packing the database. After that, re enter the entire record.

Hope this helps.

Tom Henkel

Lane Beckes
01-31-2002, 09:57 AM
I packed the record that was the problem. The database works fine now, all I had to do was reenter the record. Thanks for the help.

Lane Beckes.