PDA

View Full Version : Importing asci files


ABC123

James Watson
11-30-2001, 01:07 PM
I have a problem using Alpha V, importing from an
text file where the fields are separated by the
| or pipe character.

I can't type this into the window indicating the
field separator.

Is there any way I can enter the asci value of
this character?

Thomas Henkel
12-03-2001, 03:00 AM
If you use a script created from the IMPORT, then you have a little more flexibility. One of the options is "import.field_sep". for this you can use "chr(179)" which, from the x-basic book looks like "|" vertical bar.

Hope this helps.


Tom

James Watson
12-03-2001, 05:43 AM
Hi Thomas,

Thanks for your suggestion. It works!

The pipe of "|" character I have been trying to emulate
is actually chr(124). The asci 124 character is not
present on my Uk keyboard but I have entered
chr(124) in the field separator box on the Import card
and it works!.

I must progress to script writing but to tell the truth
we have used Alpha4 in DOS for such a long time to compile
thousands of HTML pages - that we viewed Alpha 5 with
little enthusiasm!

Many thanks for your help

James Watson