PDA

View Full Version : Strange response setting index


ABC123

James Gatton
09-14-2001, 09:00 AM
This happened to me once before (year or so ago running Win 3.1) and I had to scrap my application and start over.

Yesterday I tried to make a change in an existing index and the program wouldn't let me. Got an error of some kind and after I clicked the ok button the index I tried to modify was gone! Not only that but it wouldn't let me build any new indexs either.
I restarted the program. Didn't help.
Restarted Windows. Didn't help.
Completely shut down the machine. Didn't help.
(Thankfully, my GOBACK program enabled me to recover the lost indexes.)

Later that afternoon (being a hard head) I tried modifying an index and it worked! Also, lets me build new indexes now. Anyone have a clue as to what is causing this because it's for sure going to happen again and this is one application I definitely don't want to have to rebuild!
Jim

Thomas Henkel
09-14-2001, 09:45 AM
Try running maintenance on the .dbf. For some reason, when the dictionaries get too large, or when you have done a lot of modifications, things get strange.

We have found that indexes (compound) that have a date field as one of the fields in the index can get very strange if th edate field is blank. An"RP Corrupt" error occcues, and if you try to rebuild the index, or modify hte records, ALL indees dissappear. This gets very frustrating. Thank goodness we have nightly backups.


Tom

James Gatton
09-14-2001, 09:53 AM
Thanks, Tom. I'll give that a try.