PDA

View Full Version : posting


ABC123

Rob Weinstein
06-11-2000, 05:18 PM
I have an organizational application which includes two databases, members.dbf and dues.dbf. When a member pays dues to the organization the transaction is recorded in the dues database, and a new dues paid through date ic computed, based on the amount paid. When the transaction is saved, there is a field rule that is supposed to post the field dues->newdues to member->dues_thru (its a replace operation linked by social security number), if the logical field dues->effdues is true. When I run the application the first record saved posts correctly. After that no other dues dates post at all. Any ideas why and how to correct?

I can post by creating a post that posts all dues transactions marked true (one post operation for all, not just one at a time). That works fine, but when I create a button in the application to run the post, it runs and all the fields are updated, but there is no message that the post is done, how many records are posted, or if records were violated. Any suggestions? I could really use some advice on this one. It baffles me!

Melvin Davidson
06-13-2000, 06:18 AM
Rob,

>When I run the application the first record saved posts >correctly. After that no other dues dates post at all. Any >ideas why and how to correct?

This kind of problem is very hard to visualize, let alone debug, without seeing the actual script. My best suggestion is for you to to put a debug(1) statement into the rule so that you can trace it when it fires to find out why. Otherwise, you will need to attach code and data so that it can be reviewed.

Rob Weinstein
06-28-2000, 10:48 AM
There is no actual custom script to attach. I was trying to do everything with field rules. If you want me to attach the two databases so that someone could examine them, I can.

all I did was create a field rule that said the field "hours->newdues" should post (relpace) the field "members->duesthru", if the field "hours->effdues" is true. It posts once, then never posts again.

Melvin Davidson
06-29-2000, 05:35 AM
Rob,

I think I see what's going on. The field rule is based on a "calculated" field. Because it's calculated, A5 will detect it when a new record is entered, but somehow there's a problem when the calculated value is changed, because it is not a "user" change to the field. This might be a bug in A5, but it's a moot point because Alpha Software isn't going to fix any more problems in V1. You might have no choice but to use the script recorder to make a field rule which does the same "POST" and delete the posting rule.