PDA

View Full Version : Operation on Table gives Errors but Field Rules OK


ABC123

John Castle
03-01-2005, 07:01 AM
Has anyone come across the situation where checking the field rules in a set gives no errors and entering data in that set gives the correct results BUT if you run an operation on that set eg copy records from a table in the set to another table, the trace window gives a mass of errors about being unable to parse field rules for field X Y Z etc?

The set consists of sales order header and sales order detail and does not have a lot of field rules.

I have deleted and reinstated the field rules on some of the fields with reported trace window errors but it makes no difference.

Tom Cone Jr
03-01-2005, 07:32 AM
Is the operation completing satisfactorily, even though the trace window is filling up with errors?

-- tom

John Castle
03-02-2005, 12:00 AM
Yes it does complete ok - writes calculated fields etc to the new table.

Tom Cone Jr
03-02-2005, 12:28 AM
John,

I think you may be seeing a glitch in how the trace window is working. Perhaps others will disagree, but I'd ignore the messages that are showing up in the trace window. -- tom

Ed
03-02-2005, 04:25 AM
John:
When I see this type of error, it's usually the result of incorrect field names or object references. Did you copy a form from one table to another? In my experience, that's a primary cause of this type of error.

Open each field's and object's properties and double check to see if the names are correctly referenced, especially if the form, report, or whatever you're seeing this on was recently copied.