View Full Version : A5V8 ENT RT Won't install...


02-20-2007, 06:20 PM
I've tried to install the A5V8 ENT RT but it hangs when trying to copy the file "msscript.ocx" to the Windows System directory, and then that's it. I have to use Ctrl-Alt-Del to forcefully close the hanged installation program.

Has anyone else run across this? And if so, possible solutions?

By the way, most of the files installed, and when I try to run "Alpha5.exe" from the runtime folder, it flashes for a moment on the screen than totally disappears!

Not an exciting moment, that's for sure.

awj :( :confused: :eek:

02-20-2007, 11:05 PM
Where There's a Will, There's Always a Way!!! :)

I've determined a possible solution to this potential installation problem:

For those of you that might run into this same problem I managed to discover for the most part what the problem is. When the A5V8 Runtime Installer gets to a file titled, "msscript.ocx", it appears to hang. That's because the OCX file is continually being used by Windows (somewhere , I'm not sure) and the installer can't overwrite the file.

Before you install, what you want to do is open Windows Explorer and locate the same file above in C:\windows\system32\ and HIGHLIGHT the file and be ready to hit the delete key & confirm on that file.

Now, start to run the A5V8 Runtime installation and when it gets to the point of trying to install the "msscript.ocx" file, at this point DELETE the "msscript.ocx" file, and confirm, you might have to do it a couple of times, but that's what happened to me. Then it finally completed the installation successfully. I believe the installation program, once determining the file is gone, it will then copy the file - but it will not overwrite it.

The folks at Alpha assured me they will look into this setup problem first thing in the morning. Perhaps I was the only one to find this problem on my machines, but in the event someone else runs into this, this can do the trick.

awj :)

02-21-2007, 10:09 AM
Check out this site (and others):


02-21-2007, 10:44 AM
Hello Shawn;

Thanks for that, I also found numerous other sites like this one but it still really didn't tell me I guess what the "msscript.ocx" file's purpose really is.

I tried installing on a couple of machines and had the very same problem with that file. I'm speaking with some VB "pros" today to see if I can get some more insight on this file. Alpha Five uses it on the runtime install so it must be necessary somewhere.

I will post more info on the file when I find out some more! Thanks again!


Check out this site (and others):


Michael Humby
02-22-2007, 07:25 AM

Same thing happenened to me when I tried to install the download Runtime. Andrew's fix overcame this, many thanks.


02-22-2007, 10:35 AM
Hi All;

I spoke with some senior developers at my company and they indicated it's likely one of a few "core" files that are within the setup program to copy over to the computer when installed. The paradox is that the installer itself is using "msscript.ocx" to do it's thing yet at the same time trying to overwrite itself. In general, these Microsoft core files can be removed from the install routine to avoid this kind of thing.

As a "no worry note" the "msscript.ocx" file is of no consequence to installing the runtime. Hopefully the folks at Alpha will be able to remove that file from the installation package to avoid the "file collision" that occurred.

awj :)

Michael Humby
02-22-2007, 11:13 AM

Thanks for the 'No worry' note, that was going to be my next concern with Runtime