PDA

View Full Version : Object "nudge" Micro-Movement not working in v9?


ABC123

fsi
04-07-2008, 11:46 AM
In v8, I can select an object on a form and "nudge" it into place using the Micro-Movement key combination of control-arrow (up, down, left, right).

This doesn't seem to work in v9. If anything, the object seems to move only "coarsely."

Any others seeing this?

Or can someone confirm that it does in fact work as expected?

John Lemisch
04-07-2008, 12:49 PM
try shift key

fsi
04-07-2008, 12:57 PM
Damn. That's what I meant to say... SHIFT-arrow.

And I was looking right at my SHIFT key when I typed the post!!! :mad:


So, let me clarify.... can anyone confirm that the SHIFT-arrow method of nudging objects does work?

geez.... why can't my brain and fingers just learn to get along?

Selwyn Rabins
04-07-2008, 02:12 PM
Damn. That's what I meant to say... SHIFT-arrow.

And I was looking right at my SHIFT key when I typed the post!!! :mad:


So, let me clarify.... can anyone confirm that the SHIFT-arrow method of nudging objects does work?

geez.... why can't my brain and fingers just learn to get along?

works fine for me in v9

http://screencast.com/t/OqOP4W0kTja

fsi
04-07-2008, 02:19 PM
Thank you, Selwyn. When I try it, the hand icon appears and moves as expected (very small steps). But the object doesn't move - that is, until around five presses of the arrow key - at which point the object moves/jumps by a full (coarse) step.

Is it possible I may have unknowingly turned off Micro-Movement someplace?

Selwyn Rabins
04-07-2008, 02:23 PM
Thank you, Selwyn. When I try it, the hand icon appears and moves as expected (very small steps). But the object doesn't move - that is, until around five presses of the arrow key - at which point the object moves/jumps by a full (coarse) step.

Is it possible I may have unknowingly turned off Micro-Movement someplace?

I don't think so. there is no 'turn off' feature for micro movements

What happens if you turn off 'snap to grid'?
(Form/Grid menu)

fsi
04-07-2008, 02:27 PM
No change in behavior after turning off snap-to-grid. Mouse icon changes to hand, hand moves in small steps with each arrow press, object remains stationary until around press #4-5, then jumps full increment.

I guess if no one else has this problem, it's something I'll live with.

MikeC
04-07-2008, 10:16 PM
jon,

I know this will happen when an object is not entirely or at least not mostly within view on a form and you try to reduce the object's size with control+left arrow. To make this work you have to move the object completely on the form. This may also happen with the shift-move you are having difficulty with.

Is your object/field completely on the form? Even if so I have had similar cases that you have described. Usually all that is necessary is to unselect the object entirely (select another or...) then go back and select the wanted object again and try to move it...but also don't try to move it too far all at once--I usually try to move in 5 up to 10 increments or so--release and then move more if needed.

popellis
04-28-2008, 09:39 PM
Boy I too am having a hard time with the nudge feature in version 9. I checked to make sure that the snap to grid is turned off. I also noticed the hand moves in micro movements but looking at the grid, my actual fields seem to only move as if the snap to grid was turned on. I am selecting the field and the label. I am trying to move fields closer together vertically, the demo you referance is moving horizontal. Although it doesn't seem to really matter horizontal or verticle. It is also not consistant, sometimes I hold the shift key and then press the right arrow key, 2 key presses will get movement, another time it might be 5 key presses.

Sorry I'm lost, I had a sample form I was going to post, unfortunately the nudge works fine in this sample, maybe because my "trouble" form was originally designed in version 8. I don't know I'm at a loss.

fsi
04-28-2008, 09:48 PM
That describes the behavior I've seen - perfectly. I've not found any sequence that corrects this.

Here's another thing that I've noticed (but maybe this was the case in v8 as well)...

When setting snap-to ACTIVE/ON, the snaps are not consistent. Sometimes the object will snap to the next grid dot; sometimes in between grid dots (thus skipping the dot altogether). I allow for the possibility that it's just a monitor resolution & snap calculation issue. But the combination of micro failure and snap inconsistency makes perfection of alignment a real bear.

Tom Cone Jr
04-28-2008, 11:17 PM
But the combination of micro failure and snap inconsistency makes perfection of alignment a real bear.

Are the alignment tools not working either? Are they being used? They're on the Arrange menu.

Tim Kiebert
04-29-2008, 12:01 AM
It seems to be related to the new dynamic guidelines. These can be turned off or there sensitivity adjusted. You will find the settings under the form menu just below the grid item. I turned the guidelines off and the symptoms went away. I turned them back on and depending on the value I used for the sensitivity I could make the delay in the micromovement increase or decrease.

fsi
04-29-2008, 09:23 AM
That did it!

Form > Dynamic Guidelines > Use dynamic guidelines

After unchecking this, nudge seems to work as expected.


Many thanks to you, Tim.


P.S. Tom, alignment tools worked, but left much work for objects that were meant to be just slightly offset. And thanks to you too, Tom, as I was not aware of the feature.

gschepp
04-29-2008, 09:59 AM
Tim, that did the job!!!!

The dynamic was created mostly to work when using the mouse to move the objects I bet.

Might be better if they could somehow have an auto-off for the dynamic when using the shift and arrow keys to move the object??

Selwyn Rabins
04-29-2008, 10:28 AM
Tim, that did the job!!!!

The dynamic was created mostly to work when using the mouse to move the objects I bet.

Might be better if they could somehow have an auto-off for the dynamic when using the shift and arrow keys to move the object??

this is fixed now. will be in next update.

popellis
04-30-2008, 08:11 AM
Thanks Tim

I adjusted the settings and it works well.

As always you have the answer. Thanks for the assistance you and others give. I just wanted you to know your appreciated.

Mark

Selwyn Rabins
05-01-2008, 10:45 AM
a new update has been released, and this is now fixed