PDA

View Full Version : V10 Conditional Image Functionality


ABC123

ismac
08-21-2009, 06:27 PM
Firstly please can I add to all the praise for V10? The functionality and user friendliness for a non pro like me (an accountant), who only has a smattering of knowledge on things like Javascript, is amazing. I only wish I could have made the training session this week.

I've a problem with the conditional image, it maybe me, but I can get the conditional image display bit to work just fine, whether server or client side is selected.

However, bubble text and javascript functionality on-click etc disappear as soon as I switch the conditional expression(s) (even 1=1) from server to client side.

Is that something I've got wrong, intentional or a bug?

NoeticCC
08-21-2009, 06:51 PM
I have not had too much luck with conditional expressions on these either, never been able to pin-point exactly what worked and what didn't so could not report it but would guess 75% sure it's a bug.

peteconway
08-22-2009, 09:37 AM
It works fine.

Put your bubble text in Image Title in the properties column. Remember you are dealing with an image here not text.

Watch this video you will see the Javascript + when clicked will give you plenty of Java options.

Also be clear on the syntax

Conditional Image is; surname > "" - use double quots no IF.

if testing to shoiw hide a field: iif(surname>'',true,false) as it only want to know do it or don't do it. Single quotes.

watch this video:

http://www.screencast.com/users/iGroup/folders/Jing/media/56ae824b-3cd2-4ece-9ca4-1fd5b3dcbdfc

Peter

ismac
08-22-2009, 01:29 PM
Thanks Peter, yes it does work fine; bubble text (taken from the entry in "image title" as you say), on-click javascript, change of image etc.

But it only works when the conditions are set to server side evaluation (I notice that those in your screencast all appear to be set to server side).

If you set the condition evals to client side, image title does not display on hover, and the image stops responding to clicks etc, so any javascript doesn't run. I know this isn't a syntax issue my condition was very simple anyway: Apprvl=1, but I've tested it with the 'always on' statement 1=1 and client side fails to work properly.
It's as though switching to client side evaluation somehow disables the image.

ismac
08-22-2009, 01:44 PM
PS - Just to be clear, the conditional image changes perfectly on client side evaluation, its just the bubble text and clicking appear disabled.

peteconway
08-22-2009, 03:14 PM
Make certain pre-fetch is turned off.

ismac
08-22-2009, 04:04 PM
Thanks Peter, am I right that pre-fetch is just for detail view? If it is, I'm not using detail view. My grid is just a plain updateable grid in tabular form.

peteconway
08-23-2009, 08:32 AM
Why not contact me direct and tell me what you are trying to do. And a sample.

GarthMc
09-28-2010, 08:44 AM
Hi,

has anybody come up with a solution for this?

I have a situation where I have an conditional image I need to update when a child form closes.

If I use a client image the image updates when the child closes, but I can't get bubble help to work.

If I use a server image the bubble help works but the refresh on child form close doesn't...

thanks
garth