PDA

View Full Version : Query Genie hangs when using filters on POSGRE SQL


ABC123

gdewey
06-14-2011, 10:47 AM
I just started to use A5 and I am integrating 2 dbs on a single web application. One is Mysql (our crm) and the other Postgre sql (our ERP).

Doing all sorts of things with mysql :) it was fun untill I started to do simple grids with POSTGRE.

I make most of my queries on a query builder (not using the sql genie), but seems like the SQL GENIE does not like my sql ;) even when they runn perfectly well on the POSGRE server. Any ways, I decided to use the GENIE to re-create the query and it works fine UNTILL I add filters, since my db has a very good number of tables (more than 100), it takes tons of time to load the filter section, ones it loads and allows me to set the filters (WHERE CLAUSES) I will take tons of time again to put the sql on the text box section where it allows you to set the primary key. to start with the KEY SETTING button gives an error and second when you reopen the genie it will just hang and stay there forever (Ive tried to wait more than 1 hour). it just hangs..

so, that puts me on HAVING TO HAVE PERFECT QUERIES because I cannot change them. that is ok.

but not being able to set a primary key its something that causes the grid not to work when using a expanders. so I am totally socked in something I really need and that is very basic.. to query a posgre sql :S

any help would be apreciate it from the alpha supoprt team.. this should be a bug, dont think I am doing something wrong at all since its the same thing that worked on mysql