Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Using @font-face

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using @font-face

    Hey there,

    I'm trying to install a font but it's proving to be quite the challenge. I've found the documentation here but can't seem to get the font to load. The font only comes in otf format. Here's what I've tried:

    1. Uploaded the font to: Default.WebProject/css/fonts/VerminVibes2.otf
    2. Opened the "Edit Style in Style Builder" property in a UX component.
    3. Clicked the 'Code' tab, added the following to the top of the CSS file:
    Code:
    @font-face { 
     font-family: 'VerminVibes2';
     src: url('css/fonts/VerminVibes2.otf');
     src: url('css/fonts/VerminVibes2.otf') format('opentype');
    }
    4. Changed the font-family of a static text control to:
    Code:
    font-family: 'VerminVibes2', sans-serif;
    I've tried putting the CSS locally in the UX and changing the font-family, but no luck. I've also tried converting the font from otf to woff format using an online converter but no luck. Any suggestions?

    My Alpha Anywhere installation is on version 5487_5217.

  • #2
    Re: Using @font-face

    The file downloads and unzips as "Vermin Vibes 2.otf" with spaces... have you removed those?

    Also, if you're using Security, you must set security to Allow All Files in Folder.

    Your fonts folder needs to be published. If you're testing with LivePreview, then just copy the folder and file in place under the CSS folder.

    I added your @font-face code to a UX in the "Local CSS Definitions" property... and then changed the label of a text field to use it... setting Style to font-family: VerminVibes2;

    This worked for me...

    VerminVibes2Test.PNG
    Last edited by Davidk; 02-12-2019, 01:08 PM.

    Comment


    • #3
      Re: Using @font-face

      Thanks so much for your help David! Tried making adjustments to the css/fonts folder security settings as you suggested but still having problems getting this font to load.

      The file downloads and unzips as "Vermin Vibes 2.otf" with spaces... have you removed those?
      Yessir, renamed the file to be in Pascal casing.

      Also, if you're using Security, you must set security to Allow All Files in Folder.
      I am using security; I had right clicked the font in the Web Projects Control Panel and set the page security to always allowed. This didn't work, so I changed the css/fonts folder's security to Allow All Files in Folder as you suggested... still not getting the font to work.

      Your fonts folder needs to be published. If you're testing with LivePreview, then just copy the folder and file in place under the CSS folder.
      I'm thinking this is where the problem is. I can't seem to find where the LivePreview files are stored. Here's the file path of the font for me: <MyWorkspace>/<MyWorkSpace.WebProjects>/Default.WebProject/css/fonts

      How I added the font: I went into Web Projects Control Panel, clicked All Files on the left, opened the css folder, created and opened a fonts folder, clicked "Add File" and selected the .otf file. Is there somewhere else I should store this file?

      I added your @font-face code to a UX in the "Local CSS Definitions" property... and then changed the label of a text field to use it... setting Style to font-family: VerminVibes2;
      I tried this using VerminVibes2 and Vermin Vibes 2 (with spaces) but no luck. When I type font-family: in the CSS editor, Alpha's "intellisense" shows a lists of the fonts available, and Vermin Vibes 2 shows up with spaces. So Alpha recognizes the font through that, but it's not using that font on my static text control.

      Comment


      • #4
        Re: Using @font-face

        Regarding LivePreview... on the drive where your published files reside... if you were to perform a publish to Local Webroot... you'll find a folder name A5Webroot. Under A5Webroot you'll find the LivePreview folder... plus the folder for your Local Webroot Target Folder, if you have one.

        Under LivePreview, you'll see CSS etc. Put your fonts folder under css... so that the whole structure (viewed from Explorer) would be...

        Code:
        D:\A5Webroot\LivePreview\CSS\fonts
        My Local Webroot publishing goes to my D: drive.

        The folder you show...
        Code:
        <MyWorkspace>/<MyWorkSpace.WebProjects>/Default.WebProject/css/fonts
        is fine, but it is for your development environment... not LivePreview or Published.

        Another example from my machine is when I publish to Local Webroot. My Target Folder is "AlphaTest", and so the font resides here (shown in Explorer)...

        Code:
        D:\A5Webroot\AlphaTest\CSS\fonts
        Once you copy your fonts folder to A5Webroot\LivePreview\CSS then LivePreview of your font should work.

        Something else you can check if you're using a browser, is to right-click an empty space in the rendered page... and choose Inspect... then look at the Console tab. See if you have any errors there regarding the loading of your font.
        Last edited by Davidk; 02-12-2019, 02:00 PM.

        Comment


        • #5
          Re: Using @font-face

          THANK YOU! That was it. Really appreciate it, David!

          Comment

          Working...
          X