Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Solved: Different behavior on App server from Dev: UX and Grid

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Solved: Different behavior on App server from Dev: UX and Grid

    Running 5991-5333 on both dev (Win 10) and app (Win server 2012) machines.

    My small web app runs perfectly on the dev server. But when I publish to the company web site, I get two kinds of problems. Both types are across all parts of the application.

    1. A pop-up (.a5wcmp) screen comes up and the customer enters information. An ajax callback (Xbasic code) updates the provided info into one or more tables and sends an email. This part works just fine. But after the callback, it is supposed to go to a .a5w page to acknowledge the submission. I use a "windows.location" as the return value of the Xbasic function. Works perfectly in the dev environment. In the app server, it does all the XBasic work but does not move on to the acknowledgement page.

    2. I have a grid with the key values "hyperlinked" to open a detail page. When I click on the hyperlink, it just puts up the "wait spinner" and nothing ever happens. Again, in the dev environment, this works perfectly. But on the app server, none of the grids (there are four) opens up the detail record.

    Has anyone seen something like this? I have gone step by step through the settings on the app and dev servers and they are identical.

    Thanks for any help.

  • #2
    Re: Different behavior on App server from Dev: UX and Grid

    Build 5991-5333 has some bugs. I ran into your #2 issue. For some components I ran "Rebuild All Controls" and that fixed it.

    Or you can roll back to an earlier release, or roll the dice and try the latest pre-release.

    Comment


    • #3
      Re: Different behavior on App server from Dev: UX and Grid

      Thanks, Pizzadude,

      I upgraded both to the 1 Aug release (6012-5338). I also had high hopes for the last two, but none of them has helped.

      I tried the rebuild on all the UX controls. No change.

      Glad someone else has encountered it, though. I was feeling as though I had somehow induced this.

      thanks,
      Vincent

      Comment


      • #4
        Re: Different behavior on App server from Dev: UX and Grid

        For 2. try editing the grid ( modify some setting then modify back to original) then republish, see if that helps

        Also try cleaning your browser's cache

        Comment


        • #5
          Re: Different behavior on App server from Dev: UX and Grid

          Thank you, WindForce,

          I tried modifying the grids, to no avail. Created a brand new grid from scratch and it immediately exhibited the same behavior.

          I regularly clean my browser's cache. The problems occur no matter who goes to the web site. Some tech folks from Alpha tried it and immediately saw the problems.

          Just plain strange, this is.

          Thanks again,
          Vincent

          Comment


          • #6
            Re: Different behavior on App server from Dev: UX and Grid

            So now I'm wondering if I need to wrap my XBasic code in this: <%A5 %>
            Is that necessary in a .a5wcmp item? The online documentation indicates that it's only necessary in a .a5w file.

            Update: tried that, and it doesn't work.

            Now I'm wondering if there is some setting for the server itself (Windows Server 2012) that is interfering with the web app.

            I started the WinHttp Web Proxy Auto Discovery Service and the Application Layer Gateway Service, but the problem didn't resolve. None of the other stopped services seemed related to the situation.
            Last edited by Vincent; 08-06-2019, 09:21 AM. Reason: Further information about the troubleshooting.

            Comment


            • #7
              Re: Different behavior on App server from Dev: UX and Grid

              Capture.PNG

              Is there some guide for configuring a Windows 2012 server to support the App Server?

              Comment


              • #8
                Re: Different behavior on App server from Dev: UX and Grid

                When you say "dev environment", you mean running the entire application in localhost, right (not just"working preview" or "live preview")?

                I'd check your file references--make sure your dev machine doesn't have a path to the webroot that's different on the production machine. Remove any direct references like "https://www.myproject.com/thisonepageIwant.a5w" and also see if adding or removing a "/" before the links changes anything. A redirect should be relative to the path you're already in, so instead of "https://www.myproject.com/thisonepageIwant.a5w" it should be "/thisonepageIwant.a5w". I'm not confident that's your issue, but maybe?

                Comment


                • #9
                  Re: Different behavior on App server from Dev: UX and Grid

                  Thanks for the thoughts.
                  When I run it in dev, I am on my local PC, using localhost. When I run it on the app server, it is on a remote machine, but it still (there) uses localhost. So the connections remain the same.
                  It's a pretty small app (trouble ticket reporting) so I've kept everything in one folder. But you've given me something to try. I use "thisonepageIwant.a5w" I'll try "/thisonepageIwant.a5w" instead. Of course to go from one a5w to another hasn't been a problem. But that's all html, so maybe Java needs to process it with the backslash.
                  Thanks for the thought. I'll give it a try.

                  Comment


                  • #10
                    Re: Different behavior on App server from Dev: UX and Grid

                    Rats. No luck. I put the slash (not backslash as I misstated above) and it didn't improve the situation.

                    The key thing to me is based in this: I have a registration page. Click on a button on a .a5w page, which pops up a UX. Customer fills it out and has to enter the data for a captcha. There is a recycle button, if you want a different captcha. That button does not accomplish a change. However, if the customer fills out the info on the registration page, the underlying XBasic code (through an ajax callback) performs all required functions, updating tables and sending an email. But it then does not go to the next page. So why can the underlying function work, but the captcha won't recycle, and it won't go to the next page.

                    If anyone wants to look at the problem, go to https://mavis.katmaicorp.com/COVE and attempt the registration.

                    Comment


                    • #11
                      Re: Different behavior on App server from Dev: UX and Grid

                      Your captcha refresh is producing an error message. Check your browser console.

                      Comment


                      • #12
                        Re: Different behavior on App server from Dev: UX and Grid

                        Thanks, David,

                        I hope nobody minds that I'm being verbose here. I have benefitted most from previous posts, where a whole troubleshooting process has been captured.

                        So what I'm encountering here, all the problems, seem to have one thing in common. "Uncaught Syntax Error"

                        Capture.PNG

                        The baffling thing to me is that I don't get any of these problems when I run it in dev on my machine.

                        Why would it be inserting these "<" tokens only on the app server? I publish the same code to identically configured dev and app servers, and the dev works perfectly, while something keeps inserting a "<" token randomly throughout the code on the app server.

                        Comment


                        • #13
                          Re: Different behavior on App server from Dev: UX and Grid



                          And how in the world do I find this "VM474 a5-60125338"? I don't have 255 lines of javascript (which I assume js:255) means. Most of my code is XBasic.
                          Last edited by Vincent; 08-06-2019, 02:39 PM. Reason: for clarity

                          Comment


                          • #14
                            Re: Different behavior on App server from Dev: UX and Grid

                            I registered and got this email
                            Dear Peter Conway,

                            Katmai has received your request to add an account under
                            peteconway@xxxxx.com in your name. Please respond with an email to
                            the link below to verify this request:

                            COVE_support@katmaicorp.com

                            If you have received this mail in error, you do not need to take any
                            action. If you do not click on the link, the account will not be
                            created.

                            Sincerely,
                            Katmai Simulation & Training.
                            No errors.
                            Insanity: doing the same thing over and over again and expecting different results.
                            Albert Einstein, (attributed)
                            US (German-born) physicist (1879 - 1955)

                            Comment


                            • #15
                              Re: Different behavior on App server from Dev: UX and Grid

                              You didn't click on the Captcha recycle button... which is one of the problems he's having.

                              We also don't know what code is being returned from the XBasic function.

                              Comment

                              Working...
                              X