Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Reports not working when running multiple instances

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reports not working when running multiple instances

    So this issue has been driving me up a wall for months, I put it on the back burner while finishing up development as the system is plenty stable on a single instance, but now that full production is around the corner I am needing to figure out the solution to this issue.

    I am running multiple WAS instances on my server using always up, I can run all the instances just fine and the application works as expected except when it comes time to download/email a report generated on demand. If I have a single instance running everything works, but as soon as I start a second instance I can run the report (ie get it to display on the screen), but as when I try to click the PDF button to download (it is an HTML report) or run the xbasic code to email the report it doesn't work. Specifically when downloading and then trying to open the file it says the file is empty, and when trying to attach the pdf to the email there is no attachment. I have a feeling the issue has to do with session storage but I can't for the life of me figure out what is setup incorrectly.

    When I have multiple instances running I can go find the report file that is generated in the session storage directory (this is in the general settings pane when configuring the WAS server) and the report opens just fine so it seems when downloading/emailing the system is not able to find this location. When emailing the report I am using the e.sessionFileKey to create a blob and then saving a new file in a directory within the Webroot folder, and again this all works fine with only one instance running.

    Any thoughts on what I have setup incorrectly when it comes to the session storage? I didn't specifically setup the session storage files, in my config files for the instances it has the session storage set to "__default__" so I am assuming these session folders were generated based on that setting?

  • #2
    Re: Reports not working when running multiple instances

    Do you have separate session directories for each WAS instance? That is, if you are running three instances, are there three session directories?

    I always used specific session directores, so I don't know how it works if you leave them at default. But then I always directed the reports to a specific location outside the session directory so I always knew where it was.
    Pat Bremkamp
    MindKicks Consulting

    Comment


    • #3
      Re: Reports not working when running multiple instances

      With the config files set to default it does seem each instance has its own session folder. The issue I am having is it seems e.fileSessionKey isn’t able to find the data needed to build the blob that I would use to create a file outside the session directory so it can be attached to emails. I assume when you download a report using the PDF button on an HTML report it is using this same fileSessionKey to retrieve the data to build the PDF file. It’s as if I need all my instances going to the same session directory but I’m pretty sure I’ve tried this before which caused login issues. Do you use confit files for your instances or just mess with the settings via the WAS server settings screen? And would you mind sharing what your session storage settings look like so I can compare?

      Comment


      • #4
        Re: Reports not working when running multiple instances

        Just trying to bring more attention to this thread, still unable to run more than one instance and get my application to work (now logging in won't even work with more than one instance running).

        Comment


        • #5
          Re: Reports not working when running multiple instances

          Exactly how are you running on multiple instances, and how are you launching the reports? How you are doing this will help lead us to the answer.
          Steve Wood
          Join the ALPHA DEVELOPERS NETWORK
          There is no Cloud. It's just someone else's computer.
          Web - Mobile - Hosting - Products - Frameworks - Developer Resources
          AlphaToGo | IADN (100% Alpha Anywhere Websites)

          Comment


          • #6
            Re: Reports not working when running multiple instances

            Also, contrary to what I see in some other posts, you can and in my experience should point all of your instances to the SAME webroot and not a 'separate folder for each'; there is no need to do that. A given user should always stay in the same instance once they have first accessed your application. Session vars are not shared between instances so if for some reason they are bouncing around between instances (e.g., because you hard code a URL to point to a particular instance, or they hit a random instance each time they refresh the browser, etc) then they will lose the values for any session vars set in the other instance.
            Steve Wood
            Join the ALPHA DEVELOPERS NETWORK
            There is no Cloud. It's just someone else's computer.
            Web - Mobile - Hosting - Products - Frameworks - Developer Resources
            AlphaToGo | IADN (100% Alpha Anywhere Websites)

            Comment


            • #7
              Re: Reports not working when running multiple instances

              Zebrahost setup the instances originally, based on Alpha's documentation it looks like it was correct. They all pointed to the same webroot folder (still do), the folders I am referring to are session storage folders. Each instance is pointed to its own internal IP (Zebrahost private IPs). I am launching HTML reports which work fine in browser, it is only once you click the PDF button or try to send the PDF report using xbasic (e.sessionFileKey) that it doesn't work (no report gets emailed and the downloaded PDF is blank). I can see the report being created in the session storage folder pertaining to the old config files though so it seems the WAS is unable to locate the file using the e.sessionFileKey and therefore can't generate the report to download/send.

              I don't know if I have fixed the problem but I re-downloaded the WAS and re-setup the config files for 4 instances and now it is running. However, chances are it isn't working properly being I don't have the instances tied to individual IPs (which the Alpha documentation says to do), so likely this is just working because it is being treated as a single instance (ie I am not getting the benefit of running multiple instances or the load balancer). However, I'm not sure how to check the performance to see if what I have done has actually fixed the issue properly.

              Comment


              • #8
                Re: Reports not working when running multiple instances

                You should tell Alpha your scenario, and ask them why? Why guess when you can just ask for the answer? This is one of those cases that are not everyday use-case, you need an expert view to accommodate your issue. Remember send a test case if possible, it makes a lot of difference to the response you will get back.
                Insanity: doing the same thing over and over again and expecting different results.
                Albert Einstein, (attributed)
                US (German-born) physicist (1879 - 1955)

                Comment


                • #9
                  Re: Reports not working when running multiple instances

                  If you want to know if it is running multiple instances, you can delete all of the session folders in your a5webroot and see how many it recreates once it's in use again.

                  You'll have to make sure the a5server is OFF when you delete them so there won't be any locked files.

                  Comment


                  • #10
                    Re: Reports not working when running multiple instances

                    Have you removed AlwaysUp from the equation, just as a test?

                    I just had a weird problem crop up where my application wouldn't print PDFs (it would just hang). Everything else worked, including things like Excel exports. If I rebooted the AAS (or server itself) then things would work for 5-10 minutes and then the PDFs would hang again. Looking in the PDF queue I'd see reports of several thousand pages spooling. Even the AAS server itself eventually hung and couldn't even be restarted. I shut down AlwaysUp and ran the AAS separately and everything went back to working.

                    Again, this was just a single instance but who knows?

                    Good luck.

                    Comment

                    Working...
                    X