Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in a UX

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Barry64
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    I have the same issue. The application has worked for the last 4 years, adding fields over time. recently on the last 3 UX components where i have added a new field it has failed to bind and update. The binding and configuration of everything is correct - done it 100’s of times. The only way to get it to work is to delete all the tables/bindings, create the tables and re-bind. This is a very lengthy job to add a single new field. As I said at the start this has never happened until the last 3 occasions.

    Leave a comment:


  • scrimej
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Thanks Sean, I tried your suggestion but I am still unable to get Alpha to populate the newly added control. I'll keep trying and post any solutions I may come across as I know others are randomly encountering this issue.

    Leave a comment:


  • WebDesignShop
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Hi Jeremy,

    Have you tried deleting the action in the parent component (if it's a button - delete that) and then rebuild the button and action?

    Leave a comment:


  • Selwyn Rabins
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    you don't say what build you are using, but unless I misunderstand what you are reporting here, I don't think that there is an issue, as shown in this video

    https://www.screencast.com/t/IeeCPR0F

    Leave a comment:


  • scrimej
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Once again this issue has resurfaced for a third time. I simply added a Label control to my UX and bound that to a table that was already joined to in my Data Binding Settings.

    No matter what I do, I cannot get the value to display anything in the control (all I get is a label with an empty value for the field). I'm certain it has a value because the calling screen shows the value I'm expecting to see. It's also not tied to any specific record or value as I've tried multiple combinations...

    Another developer in our office encountered this last week. It's very annoying and currently, the only workaround I know of is a complete rebuild of the form from scratch. I tried adding the control, removing all data binding, re-binding my controls... But that seemed to make it worse as now more controls that were displaying data were now no longer displaying data. I used the Bulk Operations to rebuild the component, manifest files, etc, etc.

    I can't rebuild every form that this happens with as it seems to be something that is coming up more than I'd like.

    Leave a comment:


  • peteconway
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Re ‘Service_Status’ - Could be some reserved words in there (who knows what they are these days) try changing the name.

    Leave a comment:


  • markemoss
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Peter,


    I see what you mean with the Date/Time Field differeance, however the field that was not working properly was the Service_Status field.


    Mark

    Leave a comment:


  • peteconway
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    One is a date type and one is a time type, what happens if you make them both the same?

    Leave a comment:


  • scrimej
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    I ran into this issue last week. I ended up rebuilding the form from scratch after various attempts to resolve the problem. Hopefully the issue can be identified as the alternate solution I have is not all that practical.

    Leave a comment:


  • markemoss
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Sean,


    Thank you so much for your reply, but no the parent has many more fields than the Child, but the child is being sent the Six Fields that it needs as Arguments that the child is requesting. 5 of the 6 get and display the data correctly, but the 6th field does not and if you look it is actually the second field in the list.


    Mark

    Leave a comment:


  • WebDesignShop
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Does the parent UX list have all the same fields associated with it? I'm thinking that the parent and sibling aren't matching...

    Leave a comment:


  • Selwyn Rabins
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    please attach a test case. your test case will include both the component and a backup of the sql database.

    Leave a comment:


  • markemoss
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Selwyn,



    Thank you so much for your reply, but attached please find a Screen Shot of the 'Bind Controls for Fields' clearly showing the Service_Status field bound to the Table's Service_Status.



    Mark


    BindControls.JPG

    Leave a comment:


  • Selwyn Rabins
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    i suspect that there is no data binding defined for the 6th field whereas all of the other 5 fields have the correct data binding defined.

    Leave a comment:


  • markemoss
    replied
    Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Forum Wizards,

    I have watched your Video 'Edit the Current Row in a List Control in another UX Component' UXL-V12-49, and read the Documentation on Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in a UX

    I have created the New Child UX which has 6 fields on it and Bound it to the same table as the Parent UX. I have mapped the Data Fields from the Parent UX to the Component Fields on the Child UX. When the Parent UX invokes the Child UX it pops up with the data from the List component in the Parent UX in 5 of the 6 fields.

    I can modify and save the data in the other fields, but the 6th field does not show any data and if I place any values into it they are not saved.

    There is nothing special about this field and I have gone back and checked it against the other fields and nothing sticks out.
    Any ideas on what might cause this issue


    Mark

    Leave a comment:

Working...
X