Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Property Not Found

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Property Not Found

    Working on an application that has been used for many years here, and trying to make a change to a grid component.

    I'm able to edit and save. But when I go to publish just that component, I get this error message:
    Script: a5cwb_getGridManifest() line:24
    Property not found
    tmpl.ComponentName subelement not found.

    Any thoughts on what that means?

  • #2
    Re: Property Not Found

    When was the last time this grid was edited/uploaded to the server? (As in, how many Alpha versions ago.)

    You might try doing an update compiled files (From Bulk Operations)

    I would also exit out of Alpha and then try again.

    You might want to restore a working backup of the file before doing the compiled files update. You might even want to try getting a working backup, then try to push it again, see if you get the error even then.

    If the problem persists, you may have to recreate from scratch. (Hopefully it is not a super complicated grid.)

    Comment


    • #3
      Re: Property Not Found

      Many versions ago. I'm doing the update compiled files and will report on the results. Thank you!

      Comment


      • #4
        Re: Property Not Found

        I did the bulk operation, and it worked fine on the component, but the problem persists.

        My focus is on this part of the error message: "Script: a5cwb_getGridManifest() line:24"

        Is a script part of a component, or is it a separate file type in Alpha?

        Comment


        • #5
          Re: Property Not Found

          I would really suggest recreating the grid.

          Start but just creating the basic grid based on the same query.

          Then publish that.

          Then add things one or two things at a time and republish until it either breaks (and then you know what is causing the error) or it is finished and working.

          Alternatively, comment out code and try publishing until it works, then you know what code is breaking it. But if it is some feature that is stuck, doing this might not produce the results you are looking for.

          Comment


          • #6
            Re: Property Not Found

            You updated a grid with a current version of Alpha... that was last updated and published with an older version of Alpha... is that right?

            If so this is a common issue since new versions of Alpha remove and add stuff that older components expect or are not aware of. It's generally a mess.

            Since the error message refers to "manifest", try the Bulk Operations, Update Component Manifest files. Having to re-build the grid is inexcusable.

            Comment


            • #7
              Re: Property Not Found

              Thanks for the thoughts.
              I still haven't figured this out, but I'm now working on a different web component and am trying to add a button.
              It asks for the name and then gives me this error:
              Script:a5wcb_pageBuilder_addControl() line:121
              Property not found
              wp.page_vields[] subelement not found.

              Does this seem like there is a problem with my Alpha install? Are there scripts that are part of the Alpha product that I could examine or fix?

              Comment


              • #8
                Re: Property Not Found

                If you have already tried updating the manifest files as recommended above, I would definitely consider a complete reinstall of Alpha.

                You don't really have to uninstall it, just Reinstall it from the original files.

                Can't hurt to try.

                Also, I guess you never said what version you are currently using. If you continue to get errors and are using the latest version, I recommend going back a bit in releases to see if it works better.

                I am using build 5667, which is about 6 months old, but I have found it to be very solid. I am hoping to move to the next version. The current version apparently has some issues which may or may not be affecting you.

                The biggest issue is that, unless you apply the hotfix, it doesn't deal well with spaces in field names.

                Comment


                • #9
                  Re: Property Not Found

                  You've never indicated the version you came from and the version you're currently using.

                  Have you reported these problems to Alpha?

                  Comment


                  • #10
                    Re: Property Not Found

                    Hi, Larry and David,

                    The app was developed in 2015, so whatever version was current then is the "from" version.
                    I am currently running 12.4.6.1.2 Build 6012 with system addins build 5338.
                    Haven't reported the problem to Alpha yet. Hoped someone here would recognize the problem.
                    I'm going to start tomorrow morning with a complete reinstall (I've just been doing the 'update').
                    I did try the bulk operation to update the manifest files, and encountered a LOT of the error:
                    error in file: <fn>.a5wcmp -- You have not selected any fields for the Grid Component.

                    Comment


                    • #11
                      Re: Property Not Found

                      You never did let us know if you had tried recreating the grid. Since you appear to have more than one grid with an issue, try the simplest one. Just curious if you can get two grids side by side, both of which work but one will publish while the other one doesn't.

                      Comment


                      • #12
                        Re: Property Not Found

                        Problem resolved. I did report it to Alpha and got some advice.
                        I did a complete uninstall and a full install of the current release.
                        I updated to the current pre-release.
                        And I did two bulk operations again, with the new version: update compiled files for ajax grids and update UX components.
                        Somewhere in there the problem resolved.
                        Thanks for the offered suggestions!

                        Comment


                        • #13
                          Re: Property Not Found

                          Yup... Alpha at it's best.

                          Comment

                          Working...
                          X