Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

email attachments problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • email attachments problem

    Web app running 5667.

    I'm using the email_send_noprofile() method for sending email.

    Sending, without an attachment, gives me a nicely formatted email. If I add an attachment (in this case a PNG file) and email I receive is suddenly raw HTML. I don't understand what is going on here.

    The code I'm using for the attachment is pMesssageSettings.attachments = "C:\psspro-login-logo.png".


    Ashampoo_Snap_Monday, October 21, 2019_13h03m53s_002_.png

    Ashampoo_Snap_Monday, October 21, 2019_13h00m30s_001_.png
    Mike Brown - Contact Me
    Programmatic Technologies, LLC
    Programmatic-Technologies.com
    Independent Developer & Consultant

  • #2
    Re: email attachments problem

    Are you sure the problem is with Alpha and not your ISP, your email program or your antispam software?

    Do you have another email address that you could send the email to, just to see if it works the same? And if you are viewing it in Outlook, try your web based email instead, just to make sure. (or vice versa)

    Comment


    • #3
      Re: email attachments problem

      Been away on business so haven't been back to this. That said...

      I'm using Alpha's email_send_noprofile() to send email. I've sent the same emails to different accounts with the same results. I sent one to my gmail and viewed it in gmail (the browser). Same result. I've tried PNG and TXT files too. Same result.

      I hesitate sending this issue to Alpha because I hate sending them a problem only to find out it was something I was doing. Hence this forum post.
      Mike Brown - Contact Me
      Programmatic Technologies, LLC
      Programmatic-Technologies.com
      Independent Developer & Consultant

      Comment


      • #4
        Re: email attachments problem

        I understand.

        Does it work differently if you send it using email_send2? (I have never used no_profile.)

        Comment


        • #5
          Re: email attachments problem

          I don't know. My email is already built. Don't really want to build and test another. Further the documentation actually recommends I use EMAIL_SEND_NOPROFILE().

          Going to do a little more testing before finally asking Alpha about it.

          Thanks Larry.
          Mike Brown - Contact Me
          Programmatic Technologies, LLC
          Programmatic-Technologies.com
          Independent Developer & Consultant

          Comment


          • #6
            Re: email attachments problem

            Resolved

            Ended up being my own fault. Glad I didn't bother Alpha!

            The problem was basically a typo. I was using message and html_message simultaneously. I believe only one or the other should be used. I must have copied/paste my code from some where and probably left out the apostrophe (to comment out).

            Code:
            	'create the message detail
            	pMesssageSettings.message = whatMessage
            	pMesssageSettings.html_message = whatMessage
            	pMesssageSettings.send_to = send_to
            	pMesssageSettings.subject = subject
            Mike Brown - Contact Me
            Programmatic Technologies, LLC
            Programmatic-Technologies.com
            Independent Developer & Consultant

            Comment

            Working...
            X