Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Panel Card Fails to Display Using Next Button

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Panel Card Fails to Display Using Next Button

    Build 6232_5386

    This is a strange one. It only happens on iOS. It does not happen in working preview, live preview, or on a PC.
    So to test the attached sample component it needs to be published.

    I began seeing a seemingly random problem where a panel card does not display when navigating to it using the Next button. The problem does not happen when navigating by swiping.

    The sample component is a very simple UX designed to demonstrate the problem. It is designed to run in a browser. I am testing on an older iPad and an iPhone 11 ProMax, both running iOS 13.2.3.
    The behavior I am describing is when running Chrome on iOS. Safari has even stranger problems.

    Running it as is has no problems while using the Next button.

    But then refresh the browser, and while still viewing PANELCARD_1, click the "Add Text 1 to Text 2" button. This fetches the value in the Text_1 control and appends it to the value in the Text_2 control:

    Code:
    var _1 = {dialog.Object}.getValue('Text_1');
    var _2 = {dialog.Object}.getValue('Text_2');
    {dialog.Object}.setValue('Text_2',_1 + _2);
    Now use the Next button to navigate to Panel 3, where the Text_2 control is. Panel 3 does not display.

    It will display by tapping on the screen, or navigating away from and back to Panel 3.

    Move the Text_2 control to Panel 2 and the problem goes away. Of course, that is not an option in my production UX.



    TestPanelNavigation.zip

  • #2
    Re: Panel Card Fails to Display Using Next Button

    The problem is that you've got CRLF and Tab characters in the default text... it's formatted text... and that is messing up Alpha.

    Put your cursor into the Type property... and then tab into the Default value property. You'll see you now have scroll bars... and you shouldn't have. Now try to tab out of the Default value... you'll actually add in a Tab character... not tab to the next property.

    If you copy the Lorem ipsum text below and replace your Default value with it, you problems will go away.

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    Your default value should actually be ="Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum."

    and not just the text. I don't care if it works without the =""... you're just begging for trouble if you don't include it.

    Further, your Back button displays on PanelCard_1. Is that what you want?

    Comment


    • #3
      Re: Panel Card Fails to Display Using Next Button

      I copied and pasted this into the default values for both text controls:

      ="Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum."

      I get the same results.

      I've done some experimentation...

      I changed the default text in Text_1 to ="Add one line of text".

      I left the default in Text_2 the same as above: ="Lorem ... laborum."

      Now, if you tap the button enough times, and then tap the Next button twice, Panel 3 will not display.

      It seems as if the amount or size of the data in Text_2 causes the problem.

      If I change the last line of code on the button to:
      Code:
      {dialog.Object}.setValue('Text_2',_1 + "\n\n" + _2);
      Adding "\n\n" makes it easier to demonstrate the problem.

      Now the magic number is 7. Tap the button 6 times and Panel 3 displays just like it should. Tap it 7 times and Panel 3 does not display.

      All the controls in Panel 3 are not displaying, not just the text area control.

      And why would this only happen on iOS?

      And why does it not happen if navigating using a swipe? Why only the Next button?

      Also, I have only seen this when using panels. In my production app I have many controls that are updated by appending text to the existing value, using crlf(). I've never had a problem when using containers, and not panels.

      Comment


      • #4
        Re: Panel Card Fails to Display Using Next Button

        Here is an updated version of the sample UX.

        All text controls are deleted.

        In Panel 3 there is a list control populated by static data.

        Navigate from Panel 1 to Panel 3 using only the Next button, and Panel 3 does not display.

        Navigate from Panel 1 to Panel 3 using a swipe, and Panel 3 will display.

        Again, this must be published and opened on an iPhone or iPad to see this behavior.

        TestPanelNavigation.zip

        Comment


        • #5
          Re: Panel Card Fails to Display Using Next Button

          This feels like an Alpha bug. There is little to no testing at Alpha on iOS. I can confirm this issue. Nothing I do seems to cause the panel card contents to display.

          A PanelCard refresh() introduces another bug... and doesn't help... so... there you go.

          This behaviour is similar to your other problem... https://forum.alphasoftware.com/show...ide-expression.

          While on Panel 3, if you tap the panel... or induce any movement on that panel, the panel contents will display. This is why swiping works, but the next button doesn't.

          Your biggest problem is getting Alpha to listen, and then look at the problem. You've got a sample, it's easy to replicate using "Remote Test" (you don't need to publish), but getting Alpha to take is seriously is another story.
          Last edited by Davidk; 12-01-2019, 01:18 PM.

          Comment


          • #6
            Re: Panel Card Fails to Display Using Next Button

            Here's a temp fix... until (if) you can get Alpha to have a serious look.

            In PanelCard_3, in its onActivate event... put this code...

            Code:
            setTimeout(function(){
            	var id = $('{dialog.ComponentName}.R1.PANEL.0.PANEL.2.BODY');
            	//scroll 'element1' to top, left
            	A5.u.element.setScroll(id,1,0);
            	A5.u.element.setScroll(id,0,0);
            },25);
            Here we are using .setScroll() to move the screen by 1 pixel, and then back again. You shouldn't notice any movement or delay in seeing PanelCard_3 because it's all happening so fast.

            It's that 1px movement that is causing the screen to redraw... and therefore display PanelCard_3 contents.

            This is definitely a bug.

            Comment


            • #7
              Re: Panel Card Fails to Display Using Next Button

              I just sent a bug report. I will apply your pixel fix, thanks. Right now this is affecting a production app. Not too serious, as a swipe will still work. But I have spent a LOT of time on this.

              Comment


              • #8
                Re: Panel Card Fails to Display Using Next Button

                It is an Alpha bug. Selwyn says it is fixed, but there will not be a hotfix for the current official release 6232_5386.

                He suggested not using the built in Next/Pre buttons, but instead use {dialog.object}.panelSetActive() on the buttons.

                That seems like a lot of trouble when using a lot of panels and dynamic panels.

                The "Pixel Fix" works great, and can be easily removed after Alpha releases a version without the bug. Thank you David.

                Comment

                Working...
                X