Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

UX Fails to load after Upgrade to Build 6315 5397

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Re: UX Fails to load after Upgrade to Build 6315 5397

    I'm not surprised that your UX from Alpha 11 failed under 12. There are sweeping, fundamental changes and bugs in 12. I'd be shocked if it did upgrade. If your application is even moderately complex, moving from 11 to 12 is more of re-write.

    You might be better off upgrading incrementally. Move from 11 to one of the 1st releases of 12 and see how that behaves. If that works, then move up in pieces. Remember that Alpha has no idea what effect all it's developer's changes will have on even the last release... let alone a release from many years ago.

    You are trying to move a UX from Version 11 (and we do not know what build) through 6 years of Version 12 changes and bugs. You must see how that could never work cleanly.

    Comment


    • #17
      Re: UX Fails to load after Upgrade to Build 6315 5397

      I would expect a UX that works in build 6232 5386, released 11/12/19, (and has worked in every prior v.12 release) would work in 6315 5397, released 12/10/19.

      Comment


      • #18
        Re: UX Fails to load after Upgrade to Build 6315 5397

        One of the very useful items Selwyn has newly provided is in the pre-release notes to "Generate a File in an Ajax Callback and then Download It"

        Recommended for anyone providing file downloading
        -Steve
        sigpic

        Comment


        • #19
          Re: UX Fails to load after Upgrade to Build 6315 5397

          Selwyn has also added some excellent List InLine Editing. Excellent stuff... and so much more. What has this to do with Alpha falling over every release and the lack of testing.

          Comment


          • #20
            Re: UX Fails to load after Upgrade to Build 6315 5397

            There is another thread listing issues with SESSION VARIABLES when using Build 6315.

            https://forum.alphasoftware.com/show...variable-issue

            Has anyone experiencing the issue with UX components not loading also experienced problems with session variables failing?

            Comment


            • #21
              Re: UX Fails to load after Upgrade to Build 6315 5397

              We moved to 6344 Friday night - about 12 hours ago now. Much better, though I don't know that we had the session variables problem Greg notes in the previous post.
              -Steve
              sigpic

              Comment


              • #22
                Re: UX Fails to load after Upgrade to Build 6315 5397

                6348_5409 was released yesterday (12/22). Just FYI.
                Mike Brown - Contact Me
                Programmatic Technologies, LLC
                Programmatic-Technologies.com
                Independent Developer & Consultant

                Comment


                • #23
                  Re: UX Fails to load after Upgrade to Build 6315 5397

                  I installed 6348_5409 this morning. My original issue with a UX not loading seems to be fixed.

                  Comment


                  • #24
                    Re: UX Fails to load after Upgrade to Build 6315 5397

                    I just tried 6348-5409 as well and my UX's now load properly too.

                    However, my issue with server-side session variables not working in a show/hide expression still persists in this build (was okay in build 6232-5386).
                    Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                    Comment

                    Working...
                    X