Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Release 6315_5397 Session variable issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Release 6315_5397 Session variable issue

    Just a heads up, if your running this version look out for session variables not being set for default values of controls.
    I set the default value of the session variable using a sql statement and then set it as a default value for a control - and it has worked for a long time.
    I reverted back to 6232_5386 and they are working as expected. I also noticed some other errors related to dropdown message boxes and klass errors but the weird part is that the same application worked fine on a desktop device but NOT mobile devices - ipad and android were throwing the klass errors, nothing in the console in chrome desktop devices so I had to revert to keep things up and running as the variables set an important company_id when the component loads.

    I would submit a bug but honestly I just don't have the time to create a test case in simplicity to replicate the issue; I just know it was corrected by reverting which is always a good thing knowing I can. I look forward to the next release. I did see in the release notes that there were some sort of regressions with default values using arguments and a hotfix might be required so anyways as I said just a heads up. I am sure they'll figure it out soon.
    NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

  • #2
    Re: Release 6315_5397 Session variable issue

    Originally posted by CharlesParker View Post
    Just a heads up, if your running this version look out for session variables not being set for default values of controls.
    I set the default value of the session variable using a sql statement and then set it as a default value for a control - and it has worked for a long time.
    I reverted back to 6232_5386 and they are working as expected. I also noticed some other errors related to dropdown message boxes and klass errors but the weird part is that the same application worked fine on a desktop device but NOT mobile devices - ipad and android were throwing the klass errors, nothing in the console in chrome desktop devices so I had to revert to keep things up and running as the variables set an important company_id when the component loads.

    I would submit a bug but honestly I just don't have the time to create a test case in simplicity to replicate the issue; I just know it was corrected by reverting which is always a good thing knowing I can. I look forward to the next release. I did see in the release notes that there were some sort of regressions with default values using arguments and a hotfix might be required so anyways as I said just a heads up. I am sure they'll figure it out soon.
    Well isn't this interesting. I use session variables to show/hide a certain checkbox in some of my UX's.
    I upgraded from build 6232 to 6315 and found it to be a real disaster. So, I went back to 6232 and this morning I was notified by one of my users that they could not see the checkbox anymore.
    I tried moving the session variable show/hide expression from server-side to client-side and now it is working again. Note that this has worked for years as a server-side show hide expression ... but not now.

    So, did upgrading and then reverting back introduce this problem? That would be truly worrisome! Perhaps something else is at play, just not sure what to make of it.
    Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

    Comment


    • #3
      Re: Release 6315_5397 Session variable issue

      Originally posted by iRadiate View Post
      So, did upgrading and then reverting back introduce this problem?
      I've been bitten by this very issue in the past. It's now my practice to backup my entire project folder before updating. If I find updating to a build to be troublesome I trash the entire dev folder and restore my backup.
      Mike Brown - Contact Me
      Programmatic Technologies, LLC
      Programmatic-Technologies.com
      Independent Developer & Consultant

      Comment


      • #4
        Re: Release 6315_5397 Session variable issue

        Very good advice. I do this... plus... every time I start a development session I do a quick zip of the project folder and move that zip to a removable drive. If I'm working on something complex, I'll complete a thought, or a piece of code and zip again. Over the course of a day I may have 10 to 20 backup zips. During a development session I also duplicate the UX I'm working on. I may end up with 20 in a day. This way I know I won't lose work and time. This is the only way to combat the unknown quantity of bugs in Alpha. You never know when the environment will crash... and take your work with it.

        Comment


        • #5
          Re: Release 6315_5397 Session variable issue

          No reverting back FIXED the issue with no hassle. I find sometimes that you might have to save and republish but as Mike said - always have a backup. At least Alpha makes that easy too as well as restoring a component. Like I said many times in the past, I always try moving to the next version - if there's an error or bug I don't like ----- I can always revert back. I have to say AS has always been awesome about fixing things when a problem arises (but you will have to show it) and although I agree with DK about testing a product before it goes out the door I can sympathise with AS in that what they have created is quite a beast. We all use AS in so many different ways I doubt they could ever fully test it to be completely bug free with all the constant improvements! Overall A+ but bug reporting can be a real PIA

          Glad to hear it wasn't just me! Mine are set server side as well so maybe that's part of the problem. Maybe I'll send in a bug report this weekend if I get the time to build a working test case to show the error in action...
          NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

          Comment


          • #6
            Re: Release 6315_5397 Session variable issue

            Hi,

            I'm having this issue on a much older build of AA where the session variable is working fine on a browser but on a mobile the session does not come through?

            I'm on build 3485 - 4636

            Comment


            • #7
              Re: Release 6315_5397 Session variable issue

              When you say a "mobile" session are you talking about using say the chrome browser and accessing the same site via your phone or tablet, or do you mean you built a PGB and it doesn't work then? Those would be entirely two different issues. Add in the ability to cache things, and perhaps a cookie issue you could be having an entirely different issue and I would recommend you try debugging using your device - I think it will be difficult for you to get help from folks not on the same version, but you never know...
              NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

              Comment


              • #8
                Re: Release 6315_5397 Session variable issue

                6315 seems to have issues on mobile web browsers. For us the dates are not working. Lists that sort by dates (and have for years) stopped working.

                Comment


                • #9
                  Re: Release 6315_5397 Session variable issue

                  Originally posted by mikeallenbrown View Post
                  I've been bitten by this very issue in the past. It's now my practice to backup my entire project folder before updating. If I find updating to a build to be troublesome I trash the entire dev folder and restore my backup.
                  I use Hyper-V and my entire host machine is virtualized which makes disaster recovery very easy. Still, not something you should need to do on a regular basis!
                  Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                  Comment

                  Working...
                  X