Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

AA has become unusable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AA has become unusable

    For no apparent reason my AA is now unusable. I cannot connect to my data Script:UI_DLGBOX:A5SQLAPIConnectDlg line 40 connected = sqlconn.Open(ConnectString) An unhandled exception (c0000005) was generated.

    If I try to connect by building the string I also get an error.

    Trying to run a grid I get: Fatal error running a5_ajax_grid(): Property not found templ.preCalc.search_part subelement not found. on line 57 in 10001fa:pl

    Another error I get: Script:A5_CSWeb_GetFields() line 363 An unhandled exception (c0000005) was generated.

    I could go on. No matter what I do it's throwing errors. I used a different PC and got the same errors, I restored backup, same errors, went back to a previous version of AA - same errors.

    I was updating my online program and now it is throwing errors. I am supposed to do a demo/training session tonight at 8pm EST but I suppose I will have to call it off. I'm just a wee bit peeved. I have absolutely no idea what has gone wrong or where to turn for help except here. Does anybody have any ideas at all - please.

    Thanks

    -John

  • #2
    Re: AA has become unusable

    Originally posted by Jberry View Post
    For no apparent reason my AA is now unusable. I cannot connect to my data Script:UI_DLGBOX:A5SQLAPIConnectDlg line 40 connected = sqlconn.Open(ConnectString) An unhandled exception (c0000005) was generated.

    If I try to connect by building the string I also get an error.

    Trying to run a grid I get: Fatal error running a5_ajax_grid(): Property not found templ.preCalc.search_part subelement not found. on line 57 in 10001fa:pl

    Another error I get: Script:A5_CSWeb_GetFields() line 363 An unhandled exception (c0000005) was generated.

    I could go on. No matter what I do it's throwing errors. I used a different PC and got the same errors, I restored backup, same errors, went back to a previous version of AA - same errors.

    I was updating my online program and now it is throwing errors. I am supposed to do a demo/training session tonight at 8pm EST but I suppose I will have to call it off. I'm just a wee bit peeved. I have absolutely no idea what has gone wrong or where to turn for help except here. Does anybody have any ideas at all - please.

    Thanks

    -John
    Please reach out to us at bugs@alphasoftware.com

    Thanks
    Sarah Mitchell
    Documentation | Alpha Software Corporation
    Get in the know! Join us for our Weekly Webinars: TransForm Tuesday and Wednesday's Alpha Anywhere Demo and Q&A
    Connect with us: Instagram | Twitter | Facebook | LinkedIn | YouTube

    Comment


    • #3
      Re: AA has become unusable

      You don't mention what build of Alpha you are using.
      I was updating my online program and now it is throwing errors.
      What does this mean? What, specifically, were you doing? Updating Alpha? Republishing components? Updating your server? Updating SQL?

      Comment


      • #4
        Re: AA has become unusable

        Hi Penge,

        Thanks for replying.

        It doesn't appear to matter what I am doing, nothing is working, I only get errors. I did say what I have been trying to do - Trying to connect to my database (I get an error), - Trying you build my own connection string because the Use Named Connection String gives me an error, I get another error - (Trying to run a grid (I get an error). I am running the latest version 5418, and went back to the previous version, it gives me an error, everywhere I turn I get error, error, error. No, I cannot republish components because I can't even do anything with my grid. If I sound frustrated I apologize, but its because I am. I've no clue what has gone wrong, no clue what the error messages mean, and no clue how to fix it. As Sarah says, I can report a bug but which one? and will it be fixed before I'm supposed to show this tonight? I'd hoped it was because this is the latest version and others had said they'd had problems with it but even going back to the previous version causes errors. I realize it's probably something I have done, but it worked last night, it doesn't now, so I am completely lost and frustrated.

        Alcohol is in my future.

        If anyone can think of anything to try, please for the love of God, let me know :)

        Thanks

        -John

        Comment


        • #5
          Re: AA has become unusable

          I will submit a report and hope it is something you can fix quickly or at least tell me what to do.

          Thanks

          -John

          Comment


          • #6
            Re: AA has become unusable

            If anyone is watching this and is interested in the solution - I had to run the AccessDatabaseEngine.exe again. Selwyn thinks that MS updated the engine last night so after running it again it works. Sorry for sounding panicked (I was). I now still have time to do the demo and training at 8pm.

            Thanks

            -John

            Comment


            • #7
              Re: AA has become unusable

              Another example of the great support from Alpha, even though it had nothing to do with their software.

              Jay
              Jay Talbott
              Lexington, KY

              Comment


              • #8
                Re: AA has become unusable

                Yes indeed, and I was able to do the demo and training without having to cancel it. I was panicking though - big time.

                Thanks all.

                Comment


                • #9
                  Re: AA has become unusable

                  Originally posted by Jberry View Post
                  If anyone is watching this and is interested in the solution - I had to run the AccessDatabaseEngine.exe again. Selwyn thinks that MS updated the engine last night so after running it again it works. Sorry for sounding panicked (I was). I now still have time to do the demo and training at 8pm.

                  Thanks

                  -John
                  John, glad you got it figured out in time and thanks for posting the solution. It's always stressful when things seem to go south in a big way.
                  Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                  Comment

                  Working...
                  X