Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Linked reports, Arguments, cannot prompt for additional criteria at run time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linked reports, Arguments, cannot prompt for additional criteria at run time

    I am completely confusing myself with Arguments for Linked Reports. I have created a layout report that has THREE linked reports because I need this accounting general ledger report to show a beginning balance, the data, and an ending balance for each account based on a range of dates entered by the user. The parent layout report just queries for all accounts, and the 3 linked reports are linked to the parent via the account.

    When I open the report in the control panel, I am prompted for the begin and end dates one time and they are working properly for all the linked reports. The report opens perfectly with correct data (which THRILLED ME). Each of the linked reports have arguments for begin date, or end date, or both.

    SOOOOOO.... I created a UX component for the user to enter the begin and end dates. The genie to open the report recognizes the arguments from the report, and I bind those arguments to the begin and end date fields on the UX component. BUT when I run the report by clicking on the button on the UX component, it will not open and gives me the error: cannot prompt for additional criteria at run time

    I have searched this forum, the Alphapedia, videos, and cannot find anything that helps me.

    I am using build 1856_4237.

    Does anyone have suggestions for me?
    Carol King
    Developer of Custom Homebuilders' Solutions (CHS)
    http://www.CHSBuilderSoftware.com

  • #2
    Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

    Here's a video of what I'm trying to do: http://screencast.com/t/U4pvrAe6I0Ok
    Carol King
    Developer of Custom Homebuilders' Solutions (CHS)
    http://www.CHSBuilderSoftware.com

    Comment


    • #3
      Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

      Carol,

      It looks like you are prompting at run time for the arguments in the report. Try turning that off. Since you are passing the arguments from the UX controls, I don't think you can prompt at runtime for the input. What happens if you leave the report alone and just open it from a button on the UX? Does it prompt you for input as it does when you run the report standing alone?

      When I have run reports with parameters from a UX or grid, I did not place any arguments in the report itself, but used a local filer with arguments bound in the action javascript properties.

      Capture.PNG
      Bill Griffin
      Parkell, Inc

      Comment


      • #4
        Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

        Hi Bill, thanks for your reply. I think my issue is a bit more complex since it involves 3 linked reports that do different things with the begin and end date. 1 linked report sums data up to the begin date to get the beginning balance. Another linked report gets the data for the range of dates. Another linked report sums data up to the end date for the ending balance. Also, I remember that there used to be a place to tell reports to prompt at run time, but that's not there anymore, so I don't have anything to turn off. I did not tell it to prompt at runtime. The other thing is that as soon as I select the report in the action javascript genie, it puts the arguments from the report in and requires that I give them values. I don't have a choice to ignore them.

        I have sent this all to Alpha and Jerry is looking at it and making suggestions (which haven't worked so far). Will post what happens if we get success.
        Carol King
        Developer of Custom Homebuilders' Solutions (CHS)
        http://www.CHSBuilderSoftware.com

        Comment


        • #5
          Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

          P.S. This whole beginning and ending balance thing .... I tried like crazy to write one query that would do that for me, but failed with it. Was easily done in Access using running sums etc., but I was unsuccessful in doing that for this web app. That's why I headed to linked reports that do 3 separate queries.
          Carol King
          Developer of Custom Homebuilders' Solutions (CHS)
          http://www.CHSBuilderSoftware.com

          Comment


          • #6
            Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

            Just curious, have you tried importing the report to your web project? I had some strange issues with a report built in the 'Desktop' side that seemed to be resolved by importing the report directly to my project- then again, could have been something else with my report and this had nothing to do with it.

            I clicked the import button on the reports pane, then made sure to go back into the UX component and choose the report with the correct name @ProjectReport, and then published all changed files.

            Import Reports 1.pngImport Reports 2.png
            Last edited by marvinbase; 12-20-2013, 05:08 PM.

            Comment


            • #7
              Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

              All of my development is in the web project. No need to import, Marvin, but thanks!
              Carol King
              Developer of Custom Homebuilders' Solutions (CHS)
              http://www.CHSBuilderSoftware.com

              Comment


              • #8
                Re: Linked reports, Arguments, cannot prompt for additional criteria at run time

                Update: alpha has determined that my problem was due to a bug, which they have now fixed.
                Carol King
                Developer of Custom Homebuilders' Solutions (CHS)
                http://www.CHSBuilderSoftware.com

                Comment

                Working...
                X