Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Setting default value of control from list control when adding new record

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PaulAmmoun
    replied
    Re: Setting default value of control from list control when adding new record

    Feedback:
    as usual the solution you give works perfectly... :)
    Thanks again

    Paul

    Leave a comment:


  • PaulAmmoun
    replied
    Re: Setting default value of control from list control when adding new record

    Thanks a lot David,
    I will give it a try and let you know...

    Leave a comment:


  • Davidk
    replied
    Re: Setting default value of control from list control when adding new record

    So you want a new record... and some controls are bound? But one, or more, of them are not bound. And the setValue for those unbound controls... isn't.

    So... is your UX bound so some controls... or not bound to any controls?

    I see the same thing... but when I have no bound controls at all in my UX. The "new record" fires... and the client-side event afterAjaxCallbackComplete still fires... but it looks like... because there's no new record to actually go to, then everything is happening too quickly. It's like the afterAjaxCallbackComplete is firing before the new record is finished. Not sure if that make sense... but it kinda makes sense since there's nothing to do. My UX is not bound.

    If I do this in the afterAjaxCallbackComplete...

    Code:
    setTimeout("{dialog.Object}.setValue('text2','123411111');",100);
    Then I'm giving my setValue a fraction of a second delay... and that seems to be enough for the setValue to work. Your mileage may vary on the time. Try it and see how it works.

    Leave a comment:


  • PaulAmmoun
    replied
    Re: Setting default value of control from list control when adding new record

    Hi,
    Thanks David for the very nice video,
    I have the same issue but the control I am trying to change the value is not bound.
    When I comment the "New record action script" everything works and I am able to set the value by code.
    If the "New Record" fire then the setvalue does not work....
    I don't think the solution your provided works in my case. The same panel is activated via 2 different lists. I want to flag which list was used to activate the panel..

    Thanks

    Leave a comment:


  • jrmplus
    replied
    Re: Setting default value of control from list control when adding new record

    Hi

    Thanks for the video explanation. That was exactly what I was looking for!

    Regards

    Leave a comment:


  • Davidk
    replied
    Re: Setting default value of control from list control when adding new record

    Thanks... that was a good explanation and allowed me to build this as a solution. I think this is a good way to solve this.

    http://www.youtube.com/watch?v=gMHpNc9-n5Q

    Leave a comment:


  • jrmplus
    replied
    Re: Setting default value of control from list control when adding new record

    Hi

    The controls are all contained in one ux component with 3 panels.

    In panel 1 there is a list box which when selected, scrolls to the 2nd panel which has another list box using the first list as a parent list to filter the records.
    Selecting from this 2nd list scrolls to another panel where the record selected can be edited using bound controls. There is an add record button in this panel and when this is selected, I need one of the fields to have a default value of the primary key selected in the first list.

    I used the sample mobile app tutorial when doing most of the design work:
    http://downloads.alphasoftware.com/a...sfp=1483091238

    Regards

    Leave a comment:


  • Davidk
    replied
    Re: Setting default value of control from list control when adding new record

    Hey Jonathan,

    How are you editing the list control data with bound controls? You're in a UX... with Panels? Are you navigating to an "edit UX" which is bound?

    When you add a new record... where is that being done... in what type of component and how are you getting there?

    You can get the userAgent info from navigator.userAgent... e.g.

    Code:
    var userAgent = navigator.userAgent;
    alert(userAgent);
    When the UX renders, perform a setValue.
    Last edited by Davidk; 01-07-2014, 05:39 PM.

    Leave a comment:


  • Setting default value of control from list control when adding new record

    I've got a list control which I can edit using bound controls, but I need to be able to add new records where a few of the controls will already have default values filled in based on previous lists. (I have 3 list controls with each list being the parent list of the following list. I need to add records to the final list and there are 2 fields which need to have default values of the primary keys of the previously selected lists).

    Sorry if it sounds confusing! I assume this should be easily solved - perhaps I'm missing something obvious?
    I've looked at the samples and I can't seem to find any way of entering default values without having to manually type them in.

    Perhaps on a related issue... how can I have a field populated automatically with the mobile device/browser info, etc? I can do this is a browser grid by having the default values of a hidden control being Request.UserAgent. How can this be done in a UX component on a mobile device?

    Thanks
Working...
X