Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

UX data submit nightmare with repeating section, only when editing...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UX data submit nightmare with repeating section, only when editing...

    Hi
    I have a Customers grid, and an UX to add or edit records to that grid. In the UX i have all the customer data, and a repeating section with a child table, CustomerContacts.
    I have a button in the grid to calls the UX and sets the property when calling to "Add new record", and the CustomerID is a link that opens the UX in "edit mode".

    When adding a new customer, it works well.

    When editing an existing customer, when i click on submit in the UX, nothing happens. After investigating a bit, i see the data bounded to the Customers table get saved to the table, but the fields in the repeating section are not saved. When i watch the SQL trace window, i see sql commands going through only when i touch data in the customer part, not the repeating section.

    In the afterDialogValidate event, if i add debug(1) after the "Save data to tables" action, it does not trigger ( i.e it doesn't get there ). If i put the debug(1) before the action, it fails in the command A5DialogHelper_SaveData command with an error "variable tmpl not found" although the in the debugger tmpl is filled alright...

    All this, as stated, only happens when editing. When adding all is well. Using latest v12 build ( january 8 release )...

  • #2
    Re: UX data submit nightmare with repeating section, only when editing...

    Jaime,

    I have a grid with a button that calls a UX component to add a new record. The grid also has a link (image) that calls a second UX component to edit the record (not the same UX).
    Basically I use two nearly identical UX components, one for new records and one for editing existing records.
    Both have repeating sections and both work without issue for Insert or Update.

    I'm not sure what is going on with your UX component, but it should handle edits to the repeating section just fine.
    Is your UX dialog going dirty when you make an edit?

    Do you have Use Transactions enabled in the Server Side Action properties? This caused problems for me when not enabled.
    Edit UX.jpg

    I'm grasping at straws a bit here, but if you need to see more details of my grid/components, I'd be happy to provide more detail.
    Alpha Anywhere v12.4.6.4.0 Build 8000-5628 IIS v10.0 on Windows Server 2019 Std in Hyper-V

    Comment


    • #3
      Re: UX data submit nightmare with repeating section, only when editing...

      Hi Stephen
      I don't have any problem with the Insert, the problem is with editing. It goes dirty even when i touch a field in the repeating section, but it won't save it upon submit (submit stays on and ux stays dirty, but the parent record gets saved). Tried with transactions, same scenario...
      What build are you using?

      Comment


      • #4
        Re: UX data submit nightmare with repeating section, only when editing...

        Hi Jaime,

        I'm using the latest official release v12.2 build 1856_4237 but this has been working fine for many prior builds.
        Here's a little video showing the edit ux component. Sorry, no audio, but basically I start in the grid ... create a new record (adding a couple of items to a repeating section) and save it ... open up the newly created record for editing, add a new row to repeating section and delete an existing row, and save the edits ... open up the newly edited record to show the edits were saved.

        http://screencast.com/t/5dTpSZhnC4SO

        I think this is basically what you are trying to do if I understand correctly.
        Alpha Anywhere v12.4.6.4.0 Build 8000-5628 IIS v10.0 on Windows Server 2019 Std in Hyper-V

        Comment


        • #5
          Re: UX data submit nightmare with repeating section, only when editing...

          I know this may have NOTHING to do with it - but...
          Do any of your database fields in any of the corresponding tables contain a space?
          for example: "first name" instead of "first_name"?
          I had some very strange similar behavior due to this not too long ago...
          NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

          Comment


          • #6
            Re: UX data submit nightmare with repeating section, only when editing...

            This is an issue that is corrected with tomorrow's build.

            Comment


            • #7
              Re: UX data submit nightmare with repeating section, only when editing...

              It appears that the latest pre-release build is still 1918-4244 built on Jan 8th. Am I missing something as normally I've seen pre-release builds coming out at least once and usually twice a week?
              Brad Weaver, President
              ComputerAid International
              Ottawa ON Canada
              Versailles KY USA
              www.compuaid.com

              Comment


              • #8
                Re: UX data submit nightmare with repeating section, only when editing...

                The release numbers just haven't been updated... that's all. Yesterday's release was 1928. I download almost every day.

                Comment


                • #9
                  Re: UX data submit nightmare with repeating section, only when editing...

                  Can you provide a link to the updates? The link I have shows the last update Dec 18th
                  http://downloads.alphasoftware.com/a...chDownload.asp

                  I can't seem to find anything else...
                  NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

                  Comment


                  • #10
                    Re: UX data submit nightmare with repeating section, only when editing...

                    Never Mind - found it here
                    http://downloads.alphasoftware.com/A...easenotes.html
                    NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

                    Comment


                    • #11
                      Re: UX data submit nightmare with repeating section, only when editing...

                      I am using 1856_4237 and can also confirm that saving changes to existing records in repeating sections has become problematic.
                      It seems there is a bug here. UX's that have worked are suddenly not working.
                      I can confirm that e.dirtyColumns does not always contain all columns - see the image. Note that ENTITYID_FIN_A5INSTANCE1 is not in dirty columns list but the dataSubmitted and oldDataSubmitted show that the field is dirty.
                      Is there a known cause?

                      RepeatingSectionDirtyColumns.png

                      Note that this does not happen everywhere but does happen in components (I have 2 that are a problem) that are quite complicated and have had many changes.
                      Last edited by Garry Flanigan; 02-17-2014, 11:26 PM.

                      Comment


                      • #12
                        Re: UX data submit nightmare with repeating section, only when editing...

                        Garry
                        This has been fixed from pre-release build 1920 or 1921.

                        Jaime

                        Comment


                        • #13
                          Re: UX data submit nightmare with repeating section, only when editing...

                          Well in build 1927 it still does not work, but I contacted Selwyn and he provided a fix, which he says will be in next release.
                          The fix in my case was to put:
                          e.rtc.abort = .f.

                          just before

                          ExecuteServerSideAction("Save Data::Save_Submitted_Data_to_Tables")

                          in the afterDialogValidate event.

                          Comment


                          • #14
                            Re: UX data submit nightmare with repeating section, only when editing...

                            Originally posted by Garry Flanigan View Post
                            I am using 1856_4237 and can also confirm that saving changes to existing records in repeating sections has become problematic.
                            It seems there is a bug here. UX's that have worked are suddenly not working.
                            I can confirm that e.dirtyColumns does not always contain all columns - see the image. Note that ENTITYID_FIN_A5INSTANCE1 is not in dirty columns list but the dataSubmitted and oldDataSubmitted show that the field is dirty.
                            Is there a known cause?

                            [ATTACH=CONFIG]37663[/ATTACH]

                            Note that this does not happen everywhere but does happen in components (I have 2 that are a problem) that are quite complicated and have had many changes.
                            you are using a pre-release build. the pre-release build release notes specifically request that issues be sent to Alpha and NOT discussed on the message board because the issues don't pertain to the majority of users who use the official release.

                            the issue is only with the pre-release build you are using and only if you have defined a beforeInsert event handler. the issue has been fixed in the current pre-release.

                            Comment


                            • #15
                              Re: UX data submit nightmare with repeating section, only when editing...

                              I'm having similar problem with 1856_4237. As soon as I change any of the controls in the UX from what I had with V11, the Submit does not even reach afterDialogValidate, tested by having debug(1) as first statement in this function. If I just run the UX unchanged from when it was working in V11, it also works fine in V12.

                              Comment

                              Working...
                              X