Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Font Awesome TabbedUI Not Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Font Awesome TabbedUI Not Working

    Has anyone tried the new font-awesome library with a TabbedUI button.
    When I add an image to an existing TabbedUI button, it is not showing when published. All I get is "F001" in place of the image:

    TabbedUI.jpg

    If I create a button on a new UX component it seems to work fine (at least in working preview anyway):

    New UX.jpg

    Working for anyone else?
    Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

  • #2
    Re: Font Awesome TabbedUI Not Working

    I just notice that it's dumping a debug.log file onto my desktop:

    Code:
    [0126/133559:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133559:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133559:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133607:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133610:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133612:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133612:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133613:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133614:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133614:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133614:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133615:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133616:INFO:CONSOLE(0)] "XMLHttpRequest cannot load a5xdialog:selectedOnClick:fa-signal. Origin a5res:// is not allowed by Access-Control-Allow-Origin.," source: a5res:_self_(0)
    [0126/133616:INFO:CONSOLE(0)] "Uncaught Error: NETWORK_ERR: XMLHttpRequest Exception 101," source: a5res:_self_(10)
    [0126/133634:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1690)
    [0126/133812:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133812:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133812:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133817:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133817:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133818:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133818:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/133820:INFO:CONSOLE(0)] "XMLHttpRequest cannot load a5xdialog:selectedOnClick:fa-user. Origin a5res:// is not allowed by Access-Control-Allow-Origin.," source: a5res:_self_(0)
    [0126/133820:INFO:CONSOLE(0)] "Uncaught Error: NETWORK_ERR: XMLHttpRequest Exception 101," source: a5res:_self_(10)
    [0126/133837:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1694)
    [0126/134121:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/134121:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/134121:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/134124:INFO:CONSOLE(0)] "XMLHttpRequest cannot load a5xdialog:selectedOnClick:fa-user. Origin a5res:// is not allowed by Access-Control-Allow-Origin.," source: a5res:_self_(0)
    [0126/134124:INFO:CONSOLE(0)] "Uncaught Error: NETWORK_ERR: XMLHttpRequest Exception 101," source: a5res:_self_(10)
    [0126/134133:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1694)
    [0126/144934:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144934:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144934:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144937:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144937:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144938:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144938:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/144939:INFO:CONSOLE(0)] "XMLHttpRequest cannot load a5xdialog:selectedOnClick:fa-user. Origin a5res:// is not allowed by Access-Control-Allow-Origin.," source: a5res:_self_(0)
    [0126/144939:INFO:CONSOLE(0)] "Uncaught Error: NETWORK_ERR: XMLHttpRequest Exception 101," source: a5res:_self_(10)
    [0126/144952:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1694)
    [0126/145130:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1694)
    [0126/145130:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1690)
    [0126/145156:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145156:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145156:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145158:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145158:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145159:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145159:INFO:CONSOLE(0)] "Uncaught TypeError: Cannot read property 'tagName' of null," source: a5res:_self_(75)
    [0126/145200:INFO:CONSOLE(0)] "XMLHttpRequest cannot load a5xdialog:selectedOnClick:fa-user. Origin a5res:// is not allowed by Access-Control-Allow-Origin.," source: a5res:_self_(0)
    [0126/145200:INFO:CONSOLE(0)] "Uncaught Error: NETWORK_ERR: XMLHttpRequest Exception 101," source: a5res:_self_(10)
    [0126/145212:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1694)
    [0126/145250:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1694)
    [0126/145250:INFO:CONSOLE(0)] "Uncaught ReferenceError: A5 is not defined," source: a5res:_self_(1690)
    Appreciate if someone add a font-awesome icon to a TabbedUI button to see if it works. Otherwise, I guess I'll submit it as a bug.
    Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

    Comment


    • #3
      Re: Font Awesome TabbedUI Not Working

      From what I can see... the TabbleUI Button doesn't offer the same integration for the font-awesome images as the UX Component does. How did you add a font-awesome image to your TabbedUI Button.

      I have successfully added a font-awesome image to a Tabbed UI Button Component. I want to make sure you're in the same area I'm in before going into an explanation.

      Comment


      • #4
        Re: Font Awesome TabbedUI Not Working

        In the UX if you forget to set the css font icon property a notice window does appear and the property gets set automatically. That does not happen in the Tabbed UI. probably something not (yet) implemented for the tabbed ui.

        I just tested on a tabbed ui button. without the css fon icon property set I get no image, when I set it the image appears. So yes you may want to sent a bug report that for the tabbed ui no warning/notice appears compared to ux

        fa.png
        Frank

        Tell me and I'll forget; show me and I may remember; involve me and I'll understand

        Comment


        • #5
          Re: Font Awesome TabbedUI Not Working

          It seems that if you put a font-awesome image in a grid that no warning/notice is shown as well. Only happens for the UX
          Frank

          Tell me and I'll forget; show me and I may remember; involve me and I'll understand

          Comment


          • #6
            Re: Font Awesome TabbedUI Not Working

            Originally posted by Davidk View Post
            From what I can see... the TabbleUI Button doesn't offer the same integration for the font-awesome images as the UX Component does. How did you add a font-awesome image to your TabbedUI Button.

            I have successfully added a font-awesome image to a Tabbed UI Button Component. I want to make sure you're in the same area I'm in before going into an explanation.
            David,

            The functionality is implemented in exactly the same way as the UX component only through the TabbedUI properties.

            TUI Properties.jpg
            Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

            Comment


            • #7
              Re: Font Awesome TabbedUI Not Working

              Originally posted by Clipper87 View Post
              In the UX if you forget to set the css font icon property a notice window does appear and the property gets set automatically. That does not happen in the Tabbed UI. probably something not (yet) implemented for the tabbed ui.

              I just tested on a tabbed ui button. without the css fon icon property set I get no image, when I set it the image appears. So yes you may want to sent a bug report that for the tabbed ui no warning/notice appears compared to ux

              [ATTACH=CONFIG]37504[/ATTACH]
              Frank,

              Yes I did set the font icon in properties first but I am still not getting an image. And it's weird I'm seeing this "F001" text instead.

              Stephen
              Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

              Comment


              • #8
                Re: Font Awesome TabbedUI Not Working

                Stephen,

                You and Frank are using two different areas of the Tabbed UI... from what I can see.

                You are using "main" Tabbed UI Buttons... I believe this is what your attached image shows.

                Frank is adding components to a Tree Control. In the Tree Control, when you add components, there is a Tree Control Options set of properties among which is an Icon property. Here you can use the new Icon Fonts... as in selecting the font you want to use.

                Adding the font-awesome library to the TabbedUI is the same as in other components, but there is no facility (that I can see) for adding an Image to a Component outside a Tree Control that is the same as, for example, the UX Component.

                Are you using the Tree Control, as Frank is suggesting... or are you adding Buttons, Components, etc. as "main" level, non-Tree Control buttons? Your attached image does not suggest a Tree Control is being used.

                Comment


                • #9
                  Re: Font Awesome TabbedUI Not Working

                  Originally posted by Davidk View Post
                  Stephen,

                  You and Frank are using two different areas of the Tabbed UI... from what I can see.

                  You are using "main" Tabbed UI Buttons... I believe this is what your attached image shows.

                  Frank is adding components to a Tree Control. In the Tree Control, when you add components, there is a Tree Control Options set of properties among which is an Icon property. Here you can use the new Icon Fonts... as in selecting the font you want to use.

                  Adding the font-awesome library to the TabbedUI is the same as in other components, but there is no facility (that I can see) for adding an Image to a Component outside a Tree Control that is the same as, for example, the UX Component.

                  Are you using the Tree Control, as Frank is suggesting... or are you adding Buttons, Components, etc. as "main" level, non-Tree Control buttons? Your attached image does not suggest a Tree Control is being used.
                  David,

                  I am using the Tree Control with components. According to Selwyn's video on the new font library, it is supposed to be fully integrated into anyplace you can use an image in the TabbedUI or UX component. See here from about 1:10 of the video .. http://www.ajaxvideotutorials.com/V1..._awesome_2.swf

                  The facility to add them to the component buttons in the Tree Control does exist (see image).

                  TreeControlButton.jpg

                  I can't see where I'm doing anything wrong.
                  Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                  Comment


                  • #10
                    Re: Font Awesome TabbedUI Not Working

                    It is working here... same setup as you... now that I know you're using the Tree Control.

                    Does it work under Live Preview?

                    Do you have Security on?

                    In your Browser (Chrome or Firefox... right click and Inspect Element) are you getting any errors?

                    And you've published the CSS folder that is added to your project... containing the font-awesome stuff?
                    Attached Files

                    Comment


                    • #11
                      Re: Font Awesome TabbedUI Not Working

                      David,

                      I can't run in Live Preview as it uses session variables that don't exist in that mode.

                      I do have security on. Turned off ... makes no difference.

                      I have published the CSSIcons folder

                      Not seeing any errors when inspecting the element with firebug:

                      Element.jpg

                      I may have to contact Alpha on this one, seems to be working fine for you guys though. Arrgh.
                      Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                      Comment


                      • #12
                        Re: Font Awesome TabbedUI Not Working

                        Okay, I just made a new TabbedUI for testing purposes and it works fine there:

                        NewTabbedUI.jpg

                        So it must be "something" with my existing TabbedUI that it doesn't like :-(

                        Thanks guys for all the good suggestions.

                        Stephen
                        Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                        Comment


                        • #13
                          Re: Font Awesome TabbedUI Not Working

                          That's good, at least. Good luck with the rest. Great fonts, huh?

                          Comment


                          • #14
                            Re: Font Awesome TabbedUI Not Working

                            f001 refers to fa-music (right click on the icon selector & select view source); you could try to use another icon.
                            Frank

                            Tell me and I'll forget; show me and I may remember; involve me and I'll understand

                            Comment

                            Working...
                            X