Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Drop-down and Date Fields Don't Work.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Drop-down and Date Fields Don't Work.

    AA 12.2; Build 1958/4255. I have a grid with 3 Static, Table look-up fields, Click the drop-down arrow and the static list appears from the look-up table. Also the date field has the date picker icon and click that to choose a date. Also, typing in the drop down fields used to open the drop-down as well. Now, none of these work. The fields will allow for data to be entered but the look-up and date picker fields do not work at all. I've looked at the properties but find nothing that might cause this. Any suggestions?
    TYVM :) kenn

    Knowing what you can achieve will not become reality until you imagine and explore.

  • #2
    Re: Drop-down and Date Fields Don't Work.

    I am sure you know this but - if you have a current subscription and since that version was the latest build as of February sometime...
    http://downloads.alphasoftware.com/a...chDownload.asp


    Alpha Anywhere Updates
    The current Alpha Anywhere (Alpha Five Version 12) build is 2128_4292 (released on 29 APR 2014 09:23 AM).
    Please note that Alpha Anywhere patches are only available to users with a current subscription. You can verify your subscription status from within Alpha Anywhere by going to Help, About, or by clicking this link.
    If you install an update for which your subscription is not entitled, you will need to uninstall the update and rollback to an older version that you are authorized to use in order to continue using Alpha Anywhere.
    NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

    Comment


    • #3
      Re: Drop-down and Date Fields Don't Work.

      Yes, I am aware of this. I will not be upgrading to v2.0 simply because there is noting in it that benefits me. If this is a bug and the only way to fix it is to buy another subscription, I will look for an alternative. Thanks for your reply.
      TYVM :) kenn

      Knowing what you can achieve will not become reality until you imagine and explore.

      Comment


      • #4
        Re: Drop-down and Date Fields Don't Work.

        sorry to hear that, hope you find what you need.
        NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

        Comment


        • #5
          Re: Drop-down and Date Fields Don't Work.

          This is interesting. I opened alpha sports and created a test grid (based on the customer table) with a detail view. I set the lastname field to lookup on the customer table. Opened working preview and the dropdowns do NOT work.

          I also created a brand new workspace with one table and 3 fields and created a grid using the same process. The dropdown in the detail view works great.

          Next, I opened my workspace with v11 and found that all dropdowns and the date picker work.

          Why do the dropdowns work in a brand new workspace but not my existing workspace and Alpha Sports? Time for some sleep so will work on this in the morning. Oh, wait! It is morning, like 0233 hrs. No wonder I'm tired.
          TYVM :) kenn

          Knowing what you can achieve will not become reality until you imagine and explore.

          Comment


          • #6
            Re: Drop-down and Date Fields Don't Work.

            I recall there was an update to the internal dropdown syntax somewhere in V11. And in some case (cannot recall) you had to refresh the grid/ux, make them dirty and re-save, to get them back on track. I don't remember anything about date fields, but dropdowns went through a change.
            Steve Wood
            Join the ALPHA DEVELOPERS NETWORK
            There is no Cloud. It's just someone else's computer.
            Web - Mobile - Hosting - Products - Frameworks - Developer Resources
            AlphaToGo | IADN (100% Alpha Anywhere Websites)

            Comment


            • #7
              Re: Drop-down and Date Fields Don't Work.

              I had a problem similar to this and if I recall correctly, it had to do with a bug in alpha with the size of the drop downs. If it's not in there, try putting in "max: 3in" for the size in the properties.

              P.S. I'm finding 2.0 to be less stable and really slow with opening certain things (like the workspace itself and any lists with complex queries) so I'm actually thinking about heading into the pre releases again if there aren't any updates soon.

              Comment


              • #8
                Re: Drop-down and Date Fields Don't Work.

                I solved the problem by creating a new grid. The drop-downs and date pickers work as they should. The 64M$ question is: Was it caused by a bug or was corrupt grid? I have no clue and I doubt it's worth the effort. Unless, it happens again.

                A big Thank you to all who provided suggestions.
                TYVM :) kenn

                Knowing what you can achieve will not become reality until you imagine and explore.

                Comment

                Working...
                X