Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

List with Detail View - Issue inserting first record into List using Detail View

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • List with Detail View - Issue inserting first record into List using Detail View

    I have UX List with Detail View [Detail View is on a container that is populated from the current row] and here I am able to update the details without issue.
    I am also able to add new rows to this List by using this Detail View.

    But the issue I am having is this, when the list is empty and I am adding the new row to it, I am getting the following error:

    Error: _rdata is undefined

    I am on latest build 2446_4365.

    Regards

  • #2
    Re: List with Detail View - Issue inserting first record into List using Detail View

    Need more info.

    Working under 2446, with an empty table. A List with Detail is empty when rendered. I can add data to the detail and click Save. The record is saved without error.

    I added a filter to the List. Now the table has records but the List is empty because of the filter. I'm still able to add data into the detail section and save without error.

    So... how is your List empty?

    Post a sample UX with a table.

    Comment


    • #3
      Re: List with Detail View - Issue inserting first record into List using Detail View

      Update: Still having issue - please see the next post.
      Thanks. After reading your post I recreated basic UX lists with the above, it is working fine. I am researching what is going wrong with my existing UX. I am glad it is not a Alpha bug.
      Regards.
      Last edited by Mkpatil; 10-11-2014, 09:08 PM.

      Comment


      • #4
        Re: List with Detail View - Issue inserting first record into List using Detail View

        I found that for list detail view if I use the detail view type of Container, I am having the issue. When detail view type of Fieldmap is used there is no issue. Need to use detail view type of Container.
        1) In Working Preview the error is "Unable to get value of the property 'FIELD_KEY1'; object is null or undefined'
        2) Using WAS the error is "_rdata is undefined"
        I have attached the UX. Please see attachment. The SQL table is
        CREATE TABLE [dbo].[Table123](
        [FIELD_KEY1] [int] IDENTITY(1,1) NOT NULL,
        [FIELD_CHAR1] [char](10) NULL,
        [FIELD_NUM1] [int] NULL,
        CONSTRAINT [PK_Table123] PRIMARY KEY CLUSTERED
        (
        [FIELD_KEY1] ASC
        )WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON) ON [PRIMARY]
        ) ON [PRIMARY]

        GO
        UX_TEST1.zip

        Comment


        • #5
          Re: List with Detail View - Issue inserting first record into List using Detail View

          Yes... confirmed... it looks like an issue as you say... when the List is empty (either by a filter or no rows in the table) and the Data View Type is Container.

          Report it... that was a good one.

          And thanks for the details.

          Comment


          • #6
            Re: List with Detail View - Issue inserting first record into List using Detail View

            Thanks David. Where to report bugs?

            Regards.

            Comment


            • #7
              Re: List with Detail View - Issue inserting first record into List using Detail View

              I'll send it along... and I'll reference this thread.

              Comment


              • #8
                Re: List with Detail View - Issue inserting first record into List using Detail View

                Thank you very much.

                Regards.

                Comment


                • #9
                  Re: List with Detail View - Issue inserting first record into List using Detail View

                  This has now been corrected and will probably be in tomorrow's pre-release build.

                  Comment


                  • #10
                    Re: List with Detail View - Issue inserting first record into List using Detail View

                    awesome!

                    Regards.

                    Comment


                    • #11
                      Re: List with Detail View - Issue inserting first record into List using Detail View

                      Thanks. I was able to test the pre-release this morning and it seems to work fine in Live Preview. Pending Alpha WAS testing.

                      Regards.

                      Comment


                      • #12
                        Re: List with Detail View - Issue inserting first record into List using Detail View

                        It worked well when using Alpha Web Application server too.

                        Regards.

                        Comment


                        • #13
                          Re: List with Detail View - Issue inserting first record into List using Detail View

                          I tested this on most of my devices and still having issue with one device. Still having same issue as above with "Android Application" [used phonebuild - deleted and recreated app] - other results shown below.

                          1. iOS Safari Browser: Works fine
                          2. iOS Application (App): Works fine
                          3. Android Chrome Browser: Works fine
                          4. Android Application (App): Same error as mentioned
                          5. Windows Firefox Browser: Works fine
                          6. Windows Application (App): Did not test.

                          Regards.
                          Last edited by Mkpatil; 10-18-2014, 04:33 PM.

                          Comment

                          Working...
                          X