Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

a5w_runReport.a5w

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • a5w_runReport.a5w

    Hello,

    I'm new and just inherited a project from a colleague who retired.

    We have an existing site (hosted onsite) that we copy every year. (copy the database, alpha files + change the connection string etc.)
    I have the site for this year setup except for one issue.
    When our users click on a button to print a report. it is supposed to open a preview screen but instead it shows this error:
    Code:
    XHTTPRequest Error:
    
    500 Internal Server Error
    
    Script ErrorError:Script:"
    /ExtraService2022/__aSRunReport.aSw" line:11
    
    dim js_cmd as c=
    aSw_runReport(request,local_variables(),reportevents)
    aSw_runReport(request,local_variables(),reportevents): Too
    many parameters
    
    Alpha Anywhere Application Server Application Server/12.0
    Build/5667-5254
    I have tried many things but the only thing that worked was to copy the __a5RunReport.a5w file from last year's site to this year.

    But this file gets replaced every time i publish a change.

    is there a setting somewhere i missed?

    file that has the error
    Code:
    <%a5
    'This page is auto-generated every time files are published. It is used to print
    'reports using Ajax callbacks.
    'DO NOT MODIFY THE CODE IN THIS PAGE------------------------------------------------
    dim reportevents as p
    dim reportevents.beforePrint as p
    dim reportevents.beforePrint.hasEvent as l = .f.
    dim reportevents.afterPrint as p
    dim reportevents.afterPrint.hasEvent as l = .f.
    
    dim js_cmd as c = a5w_runReport(request,local_variables(),reportevents)
    if js_cmd <> "" then
    ? js_cmd
    end if
    %>
    file from last year (this one works)
    Code:
    <%a5
    
    
    
    
    'This page is auto-generated every time files are published. It is used to print
    'reports using Ajax callbacks.
    'DO NOT MODIFY THE CODE IN THIS PAGE------------------------------------------------
    dim localArguments as c = default ""
    dim parameterBucket as c = default ""
    dim flagLocal as c = default "No"
    dim reportName as c = default ""
    dim reportDiv as c = default ""
    dim reportIframe as c = default ""
    dim _download as c = default ""
    dim _gridId as c = default ""
    dim _clientSideFilename as c = default ""
    dim _xbasicFunction as c = default ""
    dim _reportMessagesDivId as c = default ""
    dim _pdfOpenParameters as c = default ""
    dim _hostComponent as c = default "Grid"
    dim _htmlReportContent as p
    dim _objectName as c
    
    dim _afterExecuteJavascript as c = default ""
    
    
    
    dim originalReportname as c = ""
    
    dim flagSSRSImported as l
    if atc(".ssrs@",reportName) > 0 then
    flagSSRSImported = .f.
    dim flagWorkingPreview as l = .f.
    flagWorkingPreview = a5w_FlagWorkingPreviewOrPreview()
    
    ...(rest of the code is skipped)

  • #2
    This all sounds a bit strange to me. Not sure what's being copied yearly or why. I imagine there are reasons why you do what you've been doing. I think it's going to be very difficult to nail down just what is going on.

    Is your developer and application server the same version? Have you tried reinstalling both?
    Mike Brown - Contact Me
    Programmatic Technologies, LLC
    Programmatic-Technologies.com
    Independent Developer & Consultant

    Comment


    • #3
      Thanks for the suggestion. It was a version incompatible issue.
      I updated my development IDE but not the application server.
      Took me a while to figure out that downgrading the development version doesn't work.

      As for it being a yearly copy; Not really sure why it is done this way.
      it is a once-every-year tool to used by Budget and HR to coordinate who goes into what position. (for a school district)

      Comment

      Working...
      X