Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Just wanting to give this community a heads up on an important issue I have reported relating to UX being overwritten on save

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Russell Craycraft
    replied
    I have had this issue for a while as well. (Alpha not saving changes if I do not go to the next property). I have also seen Alpha populating other textboxes when scrolling through the properties, (ie. 100% width then I can scroll down and I will see 100% in the "container in-line style" or "Break" properties.)
    This seems to happen when my RAM is full, though I could be wrong. I have an I7 with 32 gigs, and if I go to use live preview, and I hear my fan spin up, I know I need to save and restart Alpha. An Alpha restart seems to fix issues for me, but I am now in the habit of checking for windows updates and restarting my pc every morning, and rarely have these problems now.

    Leave a comment:


  • PaulAmmoun
    replied
    I use github

    Leave a comment:


  • peteconway
    replied
    Check this out - reported it but no answer - no overdrive - no nothing.

    You do not have permission to view this gallery.
    This gallery has 1 photos.

    Leave a comment:


  • Tbrondolo
    replied
    HI Pete,

    Do you use OneDrive as a repository for files. I have had similar issues to what you describe and I believe it started when I put my apps directory into OneDrive.

    Tom

    Leave a comment:


  • PaulAmmoun
    replied
    Something weird is happening to me with build 7776 :
    it seems modified dates of existing ux are being changed as an example:
    I open ux1 modify something and just save it.
    but I notice in the project manager that some other ux changes their modified date and are getting published when I publish.
    I am 100% sure I did not open these other ux

    Leave a comment:


  • peteconway
    replied

    Leave a comment:


  • gianfior85
    replied
    I can report the same exact issue happening to me in a Viewbox, in the very latest build at 7851. I can report a "test case" but as you said it only seems to occur randomly. Until I can find a reliable instance where it occurs they will not look into it I am sure.

    Leave a comment:


  • peteconway
    replied
    Well i'm glad it's not just me - I've been through all this above ..
    Pete

    Leave a comment:


  • kiwibruce
    replied
    Originally posted by Pizzadude View Post
    I have seen this happening for about the past year, maybe more. Got bit by it just the other day. I am now in the habit of tabbing to the next property before doing anything else. But this is still a definite bug.
    Yep I have hit this same problem and like you I have learned to click (Tab) to the next property just to make sure AA has committed the change.

    Leave a comment:


  • peteconway
    replied
    Thanks for letting me know - I've been starting to doubt myself on these issues - I didn't get a AA response to the video above when I sent it for investigation.

    Pete

    Leave a comment:


  • Pizzadude
    replied
    I have seen this happening for about the past year, maybe more. Got bit by it just the other day. I am now in the habit of tabbing to the next property before doing anything else. But this is still a definite bug.

    Leave a comment:


  • PaulAmmoun
    replied
    gianfior85
    Something similar happens with me,
    when I switch to a control and start changing its properties or event, it takes the ID of the previously selected control, ending up with 2 controls with the same ID.
    this happened in previous releases, but I noticed that it has something to do with the speed. meaning when I click a control sometime the IDE takes a bit of time to change the selected control. if I start edit the control directly before the IDE has a chance to update it. then the control gets the ID.
    now I learned to wait a bit before editing. I am not seeing this anymore.

    Leave a comment:


  • gianfior85
    replied
    Pete, I have not experienced this specific issue, but I have had trouble with one that seems related. Sometimes a control will randomly overwrite another control, duplicating itself (including the name which should be impossible). This is happening when I save and publish at seemingly random times. It is always will overwrite the control that has focus with the control that previous had focus before saving. This actually happens most frequently in the list layout editor (not freeform lists), but also in the components themselves. Very odd and frustrating but I can't pin down a specific scenario on which to report.

    Leave a comment:


  • peteconway
    replied
    Are you publishing whit the component open (after clicking save). -YES
    I'll try what your process, I'm now on 7821 nightly - seems fine other than that one issue -I have had the issue with 7776 onwards.
    Thanks for the heads up.
    Pete

    RE 'What happens from time to time even in older build is that the code in a specific event get erased' - yes I did see that a lot - I reported it several times and now fixed thank heavens, its the new Visual Basic Editor - had to upgrade to the 2019 build.

    Leave a comment:


  • PaulAmmoun
    replied
    Are you publishing whit the component open (after clicking save).
    Or you close the component and then publish?
    I do test and publish a lot, I never had this issue in build 7776.
    What happens from time to time even in older build is that the code in a specific event get erased.
    meaning you open the code for an event and don't change anything just close randomly and rarely I find the code in that event empty..
    This happened to me randomely.
    I find the 7776 build very good for the options I use.

    Leave a comment:

Working...
X