Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Error sending email using Action Javascript

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error sending email using Action Javascript

    Hello all, I'm using 7902. I created a button and for the OnClick I used Action JavaScript to send an email. Nothing fancy, just a test. The error I am getting is: "Message was not sent because of an error". I am clueless as to what the error is as I didn't do anything out of the ordinary.
    Anybody else run into this? Anyone know how I can fix it?

    Thanks much

    -John
    Attached Files

    #2
    Try to adjust your profile setting and make a test from there for email sending . if it works
    use email_send2() function and call your profile from there it will work

    Comment


      #3
      Okay, thanks, I'll try this today and report back. Fingers X

      Comment


        #4
        your profile email setting not within javasction property its located here as you see on the picture
        You do not have permission to view this gallery.
        This gallery has 1 photos.

        Comment


          #5
          Hello again,

          Thanks for the help. I've done this so many times I'm getting confused.

          1) I am supposed to set this up in the Settings area correct?
          2) Do I need to erase the information that is in the Project Properties?
          3) I set it up in the Settings area and when I test it I get this error: (when testing I still have it setup in both areas)

          Connect to Outgoing (SMTP) Server failed:
          The hostname might be incorrect or the server may be down.
          WSANO_DATA - Valid name, no data record of requested type while getting host name..

          Detailed Description:
          The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for.
          The usual example for this is a host name-to-address translation attempt (using gethostbyname or WSAAsyncGetHostByName)
          which uses the DNS (Domain Name Server).
          An MX record is returned but no A record—indicating the host itself exists, but is not directly reachable.



          Attached is how I have it setup in the Settings.

          Thanks for the help.

          -John



          Attached Files

          Comment


            #6
            Originally posted by Jberry View Post
            Hello again,

            Thanks for the help. I've done this so many times I'm getting confused.

            1) I am supposed to set this up in the Settings area correct?
            2) Do I need to erase the information that is in the Project Properties?
            3) I set it up in the Settings area and when I test it I get this error: (when testing I still have it setup in both areas)

            Connect to Outgoing (SMTP) Server failed:
            The hostname might be incorrect or the server may be down.
            WSANO_DATA - Valid name, no data record of requested type while getting host name..

            Detailed Description:
            The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for.
            The usual example for this is a host name-to-address translation attempt (using gethostbyname or WSAAsyncGetHostByName)
            which uses the DNS (Domain Name Server).
            An MX record is returned but no A record—indicating the host itself exists, but is not directly reachable.

            Thanks for the help.

            -John


            did u test it without ssl , try without ssl and put the port as 25 or 26
            if you manage to get this success then the function will also be success .
            for now ignore the project configuration , find out the right configuration for your email.
            are you writing the correct smtp ?

            i advice you to find the right configuration to contact your hosting provider or just simply download outlook and configure your email there
            then go to configuration on out look to find your email configuration details in there.


            Comment

            Working...
            X