Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Cordova App Freezes every time a window opens

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cordova App Freezes every time a window opens

    I have a Cordova CLI app that has been running fine on Android 7.1. Looking into getting new tablets. I tested our app on both Android 10 and 11. Every time I open a Modal-Popup window, the app appears to freeze for 3-5 seconds. If I continue to click while the app is frozen, I get the message <appname> isn't responding, with the choices to Wait or Close app. I also see the behavior with a Disclosure Menu in my control bar (a hamburger style menu that slides in from the left). I am running Alpha version 8000.

    The new tablets have more memory and better processor, and overall are faster that the old ones. It seems to be this one little hiccup that is holding them back. Anyone have any insight on this?

  • #2
    How old is your app? meaning: When was it last compiled?

    Comment


    • #3
      I usually use Instant Update to make changes. If you are asking me when is the last time I did a new baseline build in Cordova, I think it was around September of 2020.

      Comment


      • #4
        I would do a new baseline build and make sure you include the new Android versions that have been added since then. It's probably less about the processing power of your phone and more about the Android version.

        Comment


        • #5
          Thanks I will give that a try if ever I can get this darn thing to build. Been fighting it all day with countless build errors. Now I remember why I have put off doing a new baseline build for so long

          My latest error when building,
          Code:
          Failed to install ‘cordova-plugin-media’ : CordovaError: Version of installed plugin: [email protected] does not satisfy dependency plugin requirement “[email protected]
          I updated the config file to use 6.0.0 for cordova-plugin-file which acutally worked and an apk was generated. But when I open the app, it immediately errors on a line that references cordova-file (Alpha code, not mine)
          Code:
          var _srcPath = cordova.file.applicationDirectory + '/www/baseline.zip';

          Comment


          • #6
            I'm still using build 7040 from late 2020, but for Ionic (as of about a month ago) I'm using cordova-plugin-file 6.0.2 and build stack Linux - 2020.11. I'd think through any plugins with dependencies on that plugin too, like cordova-plugin-file-transfer (which should be 1.7.1).

            Good luck. I also spent a lot of my life trying to figure out what worked for me.

            Comment


            • #7
              Thanks Chris. I've tried your recommendations (cordova-plugin-file 6.0.2 and cordova-plugin-file-transfer 1.7.1). Again my build is successful, but when I install my app and open it I immediately get the error Uncaught TypeError: Cannot read properties of undefined (reading 'applicationDirectory'). It is referring to this line of code.

              Code:
              var _srcPath = cordova.file.applicationDirectory + '/www/baseline.zip';
              The baseline.zip has to do with Instant Update I believe. Perhaps you do not use Instant Update. Not sure if this is a bug or if I am just using the wrong plugin version of cordova-plugin-file. There has got to be an easier way to figure this out. The trial and error of trying different plugin versions and then building to see if it works is driving me insane.

              Comment


              • #8
                Sorry it didn't work Rusty. You're right that the baseline.zip is for Instant Update, but I'm also using Instant Update. I don't know why it's not working for you; again, I know your pain. Please post when you figure it out,

                Comment


                • #9
                  Well, to update anyone else that may have been having problems. I was able to get some help from Sarah. She recommended the AndroidX Adapter Plugin which seems to have fixed my build errors. She also recommended checking the option "Android Insecure File Mode Enabled", which seems to have helped with the errors I was getting after the app was built and installed, such as "Not allowed to load local resource" for my index.html file.

                  I feel I am getting close. Still getting the error "FileTransfer is not defined" when doing things such as refreshing a data cache or running the command DLG1_DlgObj.instantUpdateRefresh(); Over the course of trying to get this thing built, I tried different versions of both cordova-plugin-file (currently 7.0.0) and cordova-plugin-file-transfer (currently 1.7.1). Not sure if I messed something up there.
                  Capture3.jpg

                  Comment


                  • #10
                    Chris, even though I specify 6.0.2 for cordova-plugin-file in my config file, it still seems to be trying to install version 4.3.3, which then fails to install cordova-plugin-file-transfer based on my Cordova CLI output. Has anyone seen behavior like this?

                    001.png

                    Comment


                    • #11
                      Good news is I was able to successfully build. Thanks to Sarah Mitchell and everyone for the help. If anyone else was having trouble with file transfer like I was

                      <plugin name="cordova-plugin-file" source="npm" version="4.3.3" />
                      <plugin name= "cordova-plugin-file-transfer " spec= "https://github.com/remoorejr/cordova...-file-transfer " source= "git " version= "1.5.2 " />

                      Bad news is my original problem which prompted me to try a new Baseline Build remains. The app freezes for a few seconds every time a modal window is opened. I think it is related to a problem I had a while back with the number of lists I have in my app (around 50). If I don't refresh any list and my lists are empty, I do not see this behavior. However, after refreshing my lists with data from the server, I see the problem. A while back Alpha introduced a feature that would refresh every list in your app every time the screen was redrawn. Then I believe around release 7704, they fixed it to where it only refreshed the lists that were visible on screen.

                      Now before anyone jumps on me and says 50 lists is a horrible design, let me remind you that the app worked fine on Android 7. There is something about Android 10 and 11 that when a window is open, I assume it is causing some type of redraw that is causing every list in the app to be refreshed. I will reach out to Selwyn and see if he has a work around.

                      Comment


                      • #12
                        Just to follow up on my problem of modal windows freezing my app for 5 seconds or so, I found that this is not an Android 11 issue after all. I tried it on a Galaxy Tab A8 and Selwyn tried it on his phone for me. Both are running Android 11 and the app worked fine. The problem only occurs on the Chuwi HiPad X tablets that I have ordered, which also run Android 11.

                        I know some might say just don’t use the Chuwi tablets, but the problem is I just ordered like 20 of them to deploy in the field. It would be great if I can figure out what the difference is on this tablet. They both run Android 11. I went through all of the Developer Options in settings and they are pretty much the same. They both run on Android System WebView 102.0.5005.125. Both tablets are fully up to date with updates. There must be some option somewhere that I am missing, but I can’t find it.

                        Comment


                        • #13
                          Update. I've narrowed down the problem to TeamViewer Quick Support, which we use for remote support for our tablets in the field. When I install the TeamViewer Universal plugin and enable it on my Chuwi tablet, I begin experiencing the freezing of my app. However, Teamviewer makes a plugin specifically for Samsung, and when I enable it on my Samsung tablet I do not see the behavior (app freezing). I reached out to TeamViewer support with no luck.

                          Also note, I tried another product called AnyDesk. They also use a plugin for remote support (AdControl-AD1). Both the Samsung and the Chuwi use the same plugin and I do experience the same behavior (freezing) of my app on both tablets.

                          Seeing as two separate remote assist apps caused the same behavior in my app is leading me to believe that maybe it is a Cordova / Alpha issue after all.

                          Anyway, three weeks later and I am still trying to figure out the best way forward. Will continue to test different remote support apps on different tablets until I find the right combination to move forward.

                          Comment


                          • #14
                            What build are you using currently in Alpha Dev and Alpha Server? Have tried to use Ionic AppFlow?

                            Comment


                            • #15
                              I tried out Alpha build 8245 today with the same result. I have not tried Ionic AppFlow yet. It seems that for us the best solution to move forward is to simply disable the plug-in for Team Viewer Quick Support. This will allow us to offer support to remote users by viewing their screen only but won't allow us to click in the tablet. Some users also reported that the battery of their tablet was draining much faster when the plug in was enabled. I've reported to Team Viewer, so they may have a better solution in the future.

                              Comment

                              Working...
                              X