Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Web Theme Builder vs Web Style Builder for CSS, Error Msg: Fatal Error Running a5_Ajax_grid(): Property not found .....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Web Theme Builder vs Web Style Builder for CSS, Error Msg: Fatal Error Running a5_Ajax_grid(): Property not found .....

    All,
    I recently attempted to use the Web Style Builder (or is it the Web Theme Builder) and was making some progress Then I got an error similar to this:
    Fatal Error Running a5_Ajax_grid(): Property not found arr.labelInLineStyle subelement not found on line 4364 in 1000B1B:PL

    I rebuilt the tabbed UI that I had 4 controls in and it was working, but yesterday the Fatal error popped up again.

    My 1st question is which Styling tool should I be using?
    Web Style Builder accessed from Web Projects Control Panel --> More --> Open Web Style Builder
    Or
    Web Theme Builder accessed from Web Projects Control Panel - Edit --> Open Web Style Builder

    I watched most of the part 1 video on the theme builder from 2019 tool last night and will watch the rest later tonight. What I saw seemed to be more work than the Web Style Builder.

    When I started this project my project theme was a derivative of GrBlue built into alpha and it has worked for several years
    Thinking that GrBlue was an older theme I switched to Alpha-Blue yesterday but am still getting the message.
    I did most of my formatting in individual components and did not rely too much on CSS

    I can't figure out how to fix this issue.

    Thanks for any help you can offer about this topic in general or my specific error message.

    I am running Version 12.4.6.4.2, Build 8245

    Kevin






  • #2
    Well it a hornets nest at the best of times - 8245 may not be helping - send it to AA to test as a possible bug.

    Also Sarah gives some advice in this recent video http://www.viddler.com/v/11747041
    Insanity: doing the same thing over and over again and expecting different results.
    Albert Einstein, (attributed)
    US (German-born) physicist (1879 - 1955)

    Comment


    • #3
      My 1st question is which Styling tool should I be using?
      If you're using a Web Theme/Sass Theme, Web theme builder. Recommended that you move to a Web Theme/Sass Theme because that's the direction we've gone with the styles in AA.

      What I saw seemed to be more work than the Web Style Builder.
      Yep.

      Fatal Error Running a5_Ajax_grid(): Property not found arr.labelInLineStyle subelement not found on line 4364 in 1000B1B:P
      The component is failing to find a property called "labelInLineStyle". May not be related at all to the web theme. Please send us a test case that reproduces the issue. Thanks.
      Sarah Mitchell
      Director of Customer Success | Alpha Software Corporation
      Get in the know! Join us for our Weekly Webinars: TransForm Tuesday and Wednesday's Alpha Anywhere Demo and Q&A
      Connect with us: Instagram | Twitter | Facebook | LinkedIn | YouTube

      Comment


      • #4
        Pete and Sarah,
        Thank you both for your responses and Ideas.
        Working on this tonight I did find what may be the issue, although I'm not sure what the fix would be. (besides recreating the component)

        Working on the component that was not working in Grid --->Properties-->Record navigator layout.
        Clicking on the ... button brings up the error message shown in the screenshot below:
        "Property Not Found Temp.navBuilderPlaceholder subelement not found"

        Screenshot 2022-08-10 220334.jpg


        Below is what pops up when things are normal.

        Screenshot 2022-08-10 220411.jpg

        Today I am getting a little bit different error message when testing the component in Working Preview than I was getting the other day when I first reported this problem.
        Today's error message is: "Error:Script:a5_ajax_grid() line:18 Property not found tmpl.componentname subelement not found."

        Both error messages contain "subelement not found" so I'm thinking they are both happening because Temp.navBuilderPlaceholder subelement is missing.


        So my questions today are:
        1) Is there a simple fix to this (I am already well into recreating the component from scratch, but maybe someone else could benefit from a quick fix)
        2) Any idea why this might have happened? Is it simply some sort of random file corruption?
        3) Do you still think it might not be related to the Theme Builder?

        Sarah, let me know if you still think a bug report is in order and I'll attempt that. I'll keep looking for any other missing subelements.

        Thanks Much Again

        Kevin
        Last edited by Kevin at LECESSE; 08-10-2022, 10:09 PM.

        Comment


        • #5
          My Monies on it being a Bug, send the test case.
          Insanity: doing the same thing over and over again and expecting different results.
          Albert Einstein, (attributed)
          US (German-born) physicist (1879 - 1955)

          Comment


          • #6
            Originally posted by Kevin at LECESSE View Post
            let me know if you still think a bug report is in order and I'll attempt that. I'll keep looking for any other missing subelements.
            Wouldn't ask you to send a test case if we didn't want you to send a test case. I can't reproduce this, so you need to send us a reproducible test case.
            Sarah Mitchell
            Director of Customer Success | Alpha Software Corporation
            Get in the know! Join us for our Weekly Webinars: TransForm Tuesday and Wednesday's Alpha Anywhere Demo and Q&A
            Connect with us: Instagram | Twitter | Facebook | LinkedIn | YouTube

            Comment

            Working...
            X