Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

SQL Server Database Connection Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL Server Database Connection Problems

    I have been getting the following error today in any location where AA tries to access my SQL Server data. Any ideas what may be causing it? I can access the SQL Server data via the development server, so what am I missing on the live server?

    Code:
    Error: Could not connect to database.
    Reported error: Database API specific error Your database has returned the following error code and description to Alpha Anywhere. Consult your database documentation for further information. 53 - '[Microsoft][ODBC Driver 13 for SQL Server]
    Named Pipes Provider: Could not open a connection to SQL Server [53]. SQL State is: 08001 [Microsoft][ODBC Driver 13 for SQL Server]
    Login timeout expired SQL State is: HYT00 [Microsoft][ODBC Driver 13 for SQL Server]
    A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. SQL State is: 08001'
    Stephen Pilon
    Associate Librarian
    Christendom College

  • #2
    It could be a firewall or network issue? Assuming the IP address and credentials are still okay on the application server, you could try to ping the IP from the command line. If your server can't reach the database server, it's a firewall or network issue with one of the servers.

    Comment


    • #3
      The SQL Server and AA server are loaded on the same machine. The AlphaDAO strings are set (as they always have been) to the IP address of that machine. It is a Zebrahost server. So I don't see where firewall issues would be affecting it.
      Stephen Pilon
      Associate Librarian
      Christendom College

      Comment


      • #4
        Check the server port is correct and/or try a different port .. maybe something else is using that port? Just a thought.
        Alpha Anywhere v12.4.6.4.2 Build 8245-5650 IIS v10.0 on Windows Server 2019 Std in Hyper-V

        Comment


        • #5
          Ask Zebrahost it is their server being used by you - they control it.
          Insanity: doing the same thing over and over again and expecting different results.
          Albert Einstein, (attributed)
          US (German-born) physicist (1879 - 1955)

          Comment


          • #6
            We have a ticket in to Zebrahost.

            The only thing I did out of the ordinary the day it broke was try to publish my first component to the server using http publish. It was going to a different directory on the same webroot, which is what I thought the model was. Is it possible that publish changed something? It seems unlikely, but I don't really know.
            Stephen Pilon
            Associate Librarian
            Christendom College

            Comment


            • #7
              Possible - but ask them.
              Insanity: doing the same thing over and over again and expecting different results.
              Albert Einstein, (attributed)
              US (German-born) physicist (1879 - 1955)

              Comment


              • #8
                If the ticket doesn't get a response - call them. - I like them, used them years ago, they know their stuff. - BUT if 'The AlphaDAO strings are set (as they always have been) to the IP address of that machine.' - as you say - you don't need an IP address in the connection string as you are already on the same server you just need the SQL instance name.
                Insanity: doing the same thing over and over again and expecting different results.
                Albert Einstein, (attributed)
                US (German-born) physicist (1879 - 1955)

                Comment


                • #9
                  Between windows and mssql we are talking about microsoft. Never underestimate the power of a reboot.
                  Gregg
                  https://paiza.io is a great site to test and share sql code

                  Comment


                  • #10
                    OK, I changed the AlphaDAO strings in my publish profile to use the local instance. We can now get into the system, and most things work. But I have one UX component with a repeating section that just won't work. But I also see that I was using {dialog.object}.populateControlsFromTable() to populate the repeating sections, so maybe that's causing problems.
                    Stephen Pilon
                    Associate Librarian
                    Christendom College

                    Comment


                    • #11
                      So using {dialog.object}.populateControlsFromTable() is correct for loading data into the UX fields (say, after a lookup). But since I corrected my earlier problem, it seems none of my UX's like to update using {dialog.object}.populateControlsFromTable(). Do I have to rebuild all of these UX's? I've tried everything I can think of to update things (edit/save server-side scripts, etc.), but nothing is working.
                      Stephen Pilon
                      Associate Librarian
                      Christendom College

                      Comment


                      • #12
                        {dialog.object}.populateControlsFromTable().
                        two things - does this control know about the new connection string, also beyond build 8099 new parameters were preset for callback, it may be your server is not responding in time and the populateControlsFrom Tables fails - you may want to turn on the debugging option of the action.

                        Insanity: doing the same thing over and over again and expecting different results.
                        Albert Einstein, (attributed)
                        US (German-born) physicist (1879 - 1955)

                        Comment

                        Working...
                        X