Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Delay Render till visible ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Delay Render till visible ?

    Using a layout UX and embedding multiple UX components with list controls on the layout UX. I am using a menu to move through the embedded controls. I prefer to render everything on load so once the app is loaded it is quicker to move through the various embedded UX components displaying various lists. This works fine in Chrome, but when I run it on a Ipad mini, or an Iphone some of the embedded components don't render. I just get a blank screen.

    If I check delay render until visible I get a short delay with a working message, but it solves the problem. So I'm left to load it that way for now. Is there a reason why this is happening, or is it a bug? It seems inconsistent. Sometimes a panel renders, and sometimes it doesn't if I leave delay render until visible unchecked. There are 10 embedded controls on the layout UX, but the data they display is just a small amount of sample data. My back end is a mysql DB.


    I am running this on safari, in a saved to home screen browser window, not using phonegap for this app yet. Using Chrome on my development machine. Doing this via a remote server, not using remote test, or localhost.

    Bob

  • #2
    Re: Delay Render till visible ?

    Bob, did you ever resolve or fully understand this issue?
    I am grappling with mobile login issues when multiple embedded components exist. I opted to remove all embedded objects and load on demand using action java script (open a UX component) and not embed the objects. Once loaded, using the "delay render" option keeps the data loaded as long as the UX has it's own panel card. Some of my UX components require a connection so I would not use the "delay render" option.
    I have never been able to fully understand the white screen issue. The blank screen leaves the user with no option but to close and start over. It would be nice if the panel header with control bar loaded so the user can refresh if the full list control that could not be rendered. I assume there must be some server timeout setting that prevents the request from being fully completed since there are no errors or explanations for the behavior. The loading on demand has solved the problem for me since I have over 220 users and need to keep my payloads to a minimum.

    Comment


    • #3
      Re: Delay Render till visible ?

      Hey Frank,
      Still using a layout UX, and embedding sub UX components. I have a combination of renders and refreshes depending upon how I use the sub components. I can't exactly recall how this was resolved, but I did have some issues using security groups, Generally I needed to allow all security groups on the component, and applied security to a listcontrol menu like the one used in the sample mobile app. I no longer seem to have the problem, but I do contend with long load times. If it comes to me I will follow up.
      Bob

      Comment


      • #4
        Re: Delay Render till visible ?

        I have found that the browsers can have an issue with the amount of data (in terms of size) if the data is related (parent/sibling/etc.) and you are using embedded UX's. So, one way to get around this is to "unrelate" the data (in terms of parent/sibling) and relate them in another way (we use GUID's). This way, say I have a Customer, and Orders. When I create a new customer it creates a GUID on the device and stores that in a separate field (it isn't the primary key). Then, when I create a new order for that customer, it uses the GUID from the customer and puts it in a Customer_GUID field in the Orders table. When I load the embedded UX (Orders) it doesn't automatically filter the records, I tell the user to hit "refresh". This way the ux loads and all embedded ux's load, and then if they want to see updated records they just refresh.

        I realize this may seem odd and unclear, but if you want further explanation I can give it. We had to find a way to elimiate the UX wanting to refresh related data especially as it related to images....no matter what type of settings or sync policy we used....it would cause issues in app performance. So....we just found a way to unrelate them...but still relate them....and it works well.

        Comment

        Working...
        X