Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

css for dialog component

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    css for dialog component

    I have an old application with many dialog components and I need to change the color of the submit button on all of them. I am using the CSS style builder but I can not find the part or the selector that allows that change. I have converted the style sheet to make it legacy compliant. I have tried mystyleButton but changes there have no effect on the dialog submit button. What selector should I use?
    Thanks, Irwin

    #2
    Using Chrome developer tools you can drill down to see the CSS properties being applied to a button, including the style name.
    That’s the simple explanation.

    Comment


      #3
      Thanks that was useful. However inspecting the submit button shows the mystyle css style sheet and the mystlyButton selector are active but when I use the style editor to make any change and save and publish the style I do not see any change in the button. So I must be missing something. Any suggestions would be welcome.
      Thanks, Irwin

      Comment


        #4
        Try editing the css directly in the Code tab of the style builder.
        Also, try opening the component in different browsers and see if the results are the same.
        What version of Alpha are you using?
        There are a lot of things might cause this.
        Is the css being overridden in the component?
        What specifically is the name of the style in developer tools?
        Screen shots would help.


        Comment


          #5
          I am not sure if it's my editing or my publishing but changes I make have no effect. I have dozens of dialog components that look like:

          image.png

          The xbasic for this is:

          Code:
          dim tmpl as p
          tmpl.ComponentName = "m_resources"
          tmpl.ComponentType = "Dialog"
          tmpl.PreCalcMode = "Standard"
          tmpl.GUID = "b145b6bc-a01f-4740-b3ff-7882026dac91"
          
          tmpl.style_name = "npapnatucket"
          tmpl.flagUseSimpleStyles = .f.
          tmpl.show_row_labels = .t.
          tmpl.fontsize = "Medium"
          tmpl.LayoutColumns = 1
          tmpl.Position_Field_Error_Messages = "Form Header"
          tmpl.SecurityModel = "Group Based"
          tmpl.has_submit_button = .t.
          tmpl.submit_button_label  = "NPAP Resources"
          tmpl.submit_button_inlinestyle = "border-style: solid; border-width: 0; border-color: #be5e00;"
          tmpl.has_reset_button = .f.
          tmpl.Reset_button_label = "Reset"
          tmpl.Reset_button_inlinestyle = ""
          tmpl.button_alignment = "Right"
          tmpl.EditRegion.Dialog.Top = <<%txt%
          %txt%
          tmpl.EditRegion.Dialog.Bottom = <<%txt%
          %txt%
          tmpl.EditRegion.Dialog.Left = <<%txt%
          %txt%
          tmpl.EditRegion.Dialog.Right = <<%txt%
          %txt%
          tmpl.TableInLineStyle = "border-style: solid; border-width: 2px; border-color: #be5e00;"
          tmpl.ValidateBeforeSubmit = .f.
          tmpl.Declarations = ""
          tmpl.events.Initialize = ""
          tmpl.events.Activate = ""
          tmpl.events.Validate = ""
          tmpl.events.AfterValidate = <<%code%
          CurrentForm.RedirectTarget="Resources.a5w"
          %code%
          tmpl.fields = 1
          DIM tmpl.Variable_Info[tmpl.fields] as P
          with tmpl.Variable_Info[1]
              .Fieldname = "Hidden0"
              .Scope = "Local"
              .Type = "C"
              .Varname = "HIDDEN0"
              .Column.LabelPosition = "Left"
              .Controltype = "Hidden"
              .InitialValue = ""
              .BreakType = "None"
              .nCols = 1
              .Column.Hide = .t.
          end with


          The line tmpl.TableInLineStyle = "border-style: solid; border-width: 2px; border-color: #be5e00;" shows that the color of the text is not defined and I want to change it (for example to red). But I don't want to edit every component but do it via css.
          I inspected the button in chrome and attaching 3 screens that may be useful

          Also the a5w page containing this component contains:
          <!--Alpha Five Temporary Code Start - Will be automatically removed when page is published -->
          <!--CSS for tmpl_m_resources -->
          <link rel="stylesheet" type="text/css" href="file:///C:/A5V9/npap/npap.WebProjects/Default.WebProject/css/npapnatucket/style.css">
          <!--Alpha Five Temporary Code End -->

          And when executed online it contains
          [TD]<link rel="stylesheet" type="text/css" href="css/npapnatucket/style.css">[/TD]
          [TD]<link rel="stylesheet" type="text/css" href="css/npapnatucket/components/a5SimpleForm/style.css">[/TD]

          So I am confused if I am even working on the right css file as there are other ones in other folders in the webroot.
          I have added the line for color as
          Code:
          font-family: tahoma, verdana, arial, helvetica;
          color: #ff0000;
          font-size: 13px;
          using the style builder and by editing the css file with no effect.
          Thanks for your help,
          Irwin
          Attached Files

          Comment

          Working...
          X