Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Different results from same publish

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Different results from same publish

    I have a real puzzler. I have published the same application to my localhost and to my test server. I am running the same SQLServer database for both. The puzzler - when I run a query, I get different results. On localhost, it runs fine. On my test server, it comes back with "no records in report". I tried to upload a screenprint, but the forum just gives me an error when I try to upload. It also won't let me delete previously uploaded files.

  • #2
    Re: Different results from same publish

    The connection strings may not be in sync or there may be a security issue.

    Comment


    • #3
      Re: Different results from same publish

      I don't understand what you mean. How can the connection strings or security be different when it is the same database and I published the same application?

      Comment


      • #4
        Re: Different results from same publish

        Look under tools/AlphaDAO Connections.

        Then look under profiles/Named AlphaDAO connection strings/AlphaDAO Connections.

        Do they match?

        Comment


        • #5
          Re: Different results from same publish

          Yes, they match. Both Localhost and the Test server get data on other screens, but localhost gets results when run reports and test server does not.

          Comment


          • #6
            Re: Different results from same publish

            Are you running the report the same way? Are the variables being set the same way local and on test?

            Comment


            • #7
              Re: Different results from same publish

              I used the exact same criteria for the reports on both the local and on test. I re-published again this morning, paying close attention that all the publishing factors were the same. They were. Test had same results - no data on reports.
              Published all files in project
              Published Workspace library
              compiled functions into an .AEX file

              Comment


              • #8
                Re: Different results from same publish

                if you have modified the report the library needs to be published.
                would you check and see if that is published when you publish, you can check before you click ok button I think. include workspace library in the publish dialog if it is not already checked.
                thanks for reading

                gandhi

                version 11 3381 - 4096
                mysql backend
                http://www.alphawebprogramming.blogspot.com
                [email protected]
                Skype:[email protected]
                1 914 924 5171

                Comment


                • #9
                  Re: Different results from same publish

                  Originally posted by GGandhi View Post
                  if you have modified the report the library needs to be published.
                  would you check and see if that is published when you publish, you can check before you click ok button I think. include workspace library in the publish dialog if it is not already checked.
                  I did include the workspace library (reports) because I knew I had modified them. I used the exact same publish values/checkboxes for publishing to both localhost and test server within a couple minutes of each other without any code or report or any other changes in-between.

                  Comment


                  • #10
                    Re: Different results from same publish

                    Solved problem by re-booting the test server.

                    Comment


                    • #11
                      Re: Different results from same publish

                      I hate when that happens.

                      Comment

                      Working...
                      X