Hi

I have an (almost) completed mobile app which has a number of time controls that are defined as Control Type=Textbox, Field Type=Short-time, HTML5 type=time, Display format=time("0h:0m",<value>). These fields are data bound to a SQL Server table where the columns are defined as TIME. I'm currently testing my app and have noticed an odd effect.

If I run the app on either an iPad (Safari) or Android tablet (Chrome) from the development server it displays the time fields correctly (they look like combo boxes but when touched I get a spin list to adjust the values).

If I run the same app as above but from my production server, which is running the standard Alpha Application server (Version 12), the current field values are not displayed - the fields are blank. If I touch the field I get the popup spin list which displays the current device time. If I select a time via the spin list the control then displays the time selected.

Does anyone know why this behaviour is different between the development and production servers?

I've attached a couple of screenshots showing the difference.

Thanks in advance.
Tiran

Edit: When running on the production server, the time fields do not update to the database either, all other fields update OK (everything works fine from the development server!). So, there must be a problem with the production server handling this type of field or I have a configuration error somewhere.
Attached Files