Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Cannot Get Phonegap to Work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Get Phonegap to Work

    Just installed phonegap for desktop. Created a simple application and uploaded to the Adobe servers. Application does not work. It will not display the button lists I created, only the title. I looked at the WWW folder created under my webprojects and noticed that the index.html file does not display the button lists either. Upon inspection, their is a console error that the phonegap.js file failed to load. Did I miss a step somewhere along the line or is their an issue with the button lists working with phonegap?
    Thanks,
    James

  • #2
    Re: Cannot Get Phonegap to Work

    Did you read the getting started guide?

    After getting started my advice is to start right a way using phonegap shell.

    Comment


    • #3
      Re: Cannot Get Phonegap to Work

      Hi James,

      No issues that I can see with using the Button List control and a PhoneGap Build app. I just tried it to make sure and it's ok. What build of Alpha are you using? If it's a really simple app could you zip your project, including all it's sub-folders and post it here. I'll create a PGB app and see what's going wrong. If your using a SQL table, dump and post it as well. I know it's a bit of an effort, but doing this will establish what's going wrong. Otherwise, it's just a guess. The sub-folders will include the PhoneGapProjects folder which will have the settings for the PhoneGap Builder that you used. You can remove the PGB password and userid if you want, plus the Ajax Callback URL - I won't need those.

      Sometimes, getting everything properly set up is a bit troublesome... there are so many options and paths to take.

      Comment


      • #4
        Re: Cannot Get Phonegap to Work

        Ken, I used the getting started guide to model my application after except I added a third party plugin in and 8 button lists. The issue is, the application can not find the "phonegap.js" file. Does anyone know where this file comes from? Does the Alpha 5 phonegap builder generate this file or is it a standard file from phonegap?

        Was I supposed to install the phonegap CLI instead of the windows installer?

        David, I will try and create a new app that I can send to you where I strip out the details. If this solves my problem, I will revisit my code although its pretty straight; all javascript and no Ajax.
        Thanks,
        James

        Comment


        • #5
          Re: Cannot Get Phonegap to Work

          David, one other answer to your questions. I am using the latest official release of Alpha. No pre-release.
          Thanks,
          James

          Comment


          • #6
            Re: Cannot Get Phonegap to Work

            Originally posted by jhackney View Post
            The issue is, the application can not find the "phonegap.js" file. Does anyone know where this file comes from? Does the Alpha 5 phonegap builder generate this file or is it a standard file from phonegap?

            Was I supposed to install the phonegap CLI instead of the windows installer?
            PhoneGap Build injects phonegap.js - it comes from PGB. The Alpha PhoneGap Build Builder ensures the line to include this source file is included in the index.html file that the builder creates.

            You do not need to install the PhoneGap CLI. Neither the Alpha PhoneGap Build Builder nor the PhoneGap Build service need it to be installed on your machine.

            Comment


            • #7
              Re: Cannot Get Phonegap to Work

              David, thanks. I didn't think it needed me to install it. I started from scratch to create an example you can look at and I came up with the same issue. Open up the attached zip and run the UX in working preview. Notice the working button lists in menu option 1 and 2. Now look at the "www" folder and open the index.htm file. The button lists do not work. Let me know if you have any ideas. I had to link the zip because of the size.

              https://files.secureserver.net/0sRYkUA58gwpX9
              Thanks,
              James

              Comment


              • #8
                Re: Cannot Get Phonegap to Work

                David, no need to look at my file. There is an apparent bug when you use a button list that uses a data series that uses a javascript function for the data. I was able to get the button lists to work using either the button generator or the static json. I will submit this to Alpha. Just my luck on my first try at a phonegap build I run into a bug.

                Thanks for your help.
                Thanks,
                James

                Comment


                • #9
                  Re: Cannot Get Phonegap to Work

                  That's the conclusion I came to as well, James. I'd just finished building a test... and when I saw you were using a Data Series, I figured that was the cause. And... using Data Series from a javascript function call... which complicates things even more. Glad you found it. Keep going.

                  Comment

                  Working...
                  X