Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Xbasic function savefile not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xbasic function savefile not working

    My file upload works fine in V11, however after switching to V12. Alpha wants you to change from e.fileArray.data to e.fileArray.fileName when doing so my uploads become corrupt and will not open.
    Has anyone had this problem or know how to fix it?
    Thanks

    function saveFile as v (e as p)
    debug(1)
    dim count as n
    count= e.filecount
    dim i as n
    dim fntostore as c
    dim arr as p
    arr = e.filearray

    dim tbl as p
    tbl = table.open("[PathAlias.ADB_Path]\myuploads",FILE_RW_SHARED)

    for i = 1 to count
    dim fn as c
    dim data as b
    data= e.fileArray[i].fileName

    fn = "C:\A5Webroot\myuploads" + chr(92) + e.filearray[i].fileName

    file.From_blob(fn,data)

    dim fntostore as c
    fntostore = e.fileArray[i].filename

    tbl.enter_begin()

    tbl.ponumbers = e.primarykeyArray[1]
    tbl.linkedfilename = fntoStore
    tbl.enter_end()


    next i
    e.javescript = "window.parent.{grid.object}.refresh();"
    end function

  • #2
    Re: Xbasic function savefile not working

    I'm assuming you're using the Action - File Upload-User Defined.

    You write that Alpha wants you to change, and for good reason, but you don't have to. However, if you do want to change, then your code must change as well. In the action property... XBasic function argument array mode... you need to set this to 'filename'. In your code you're treating the upload as if it's data. You've got dim data as b, data = e.fileArray[i].fileName, then you're converting the filename from a blob to a file. This is where you're problem is. By using 'filename' you've already got the uploaded file, with a temp name held in e.fileArray[i].tempFileUploadedData and you've got the original filename in e.fileArray.fileName. So with all this information you can rename and move the file if you want to.

    Comment


    • #3
      Re: Xbasic function savefile not working

      Originally posted by Davidk View Post
      I'm assuming you're using the Action - File Upload-User Defined.

      You write that Alpha wants you to change, and for good reason, but you don't have to. However, if you do want to change, then your code must change as well. In the action property... XBasic function argument array mode... you need to set this to 'filename'. In your code you're treating the upload as if it's data. You've got dim data as b, data = e.fileArray[i].fileName, then you're converting the filename from a blob to a file. This is where you're problem is. By using 'filename' you've already got the uploaded file, with a temp name held in e.fileArray[i].tempFileUploadedData and you've got the original filename in e.fileArray.fileName. So with all this information you can rename and move the file if you want to.
      David thank you. Yes I'm using File Upload Defined.

      I changed the "b" to a c and removed the blob and thought I could replace it with file.filename_parse(fn,data) but no file would upload (save to the location) Sorry I'm very limited in the Xbasic for this one.

      Thank for the help.

      Comment


      • #4
        Re: Xbasic function savefile not working

        Hey John,

        File Upload - User Defined uploads the file or files automatically. They are uploaded, usually, to a temp folder and with a temp name. The filename is a temp name, but the file extension is always the same as the source file uploaded. Your XBasic code runs AFTER the auto-upload takes place... in order to figure out what you want to do with the already uploaded file(s). file.filename_parse(fn,data) is a completely wrong use of file.filename_parse() method. file.filename_parse() parses a fully qualified filename.ext and returns a specific piece of that filename.

        E.g. if filename is K:\PROGRAM FILES\A5V4\TEMPLATES\DATABASES\INVOICE\CUSTOMER.DBF

        then

        dim fname as c = file.filename_parse(filename,"n")

        would set fname to CUSTOMER

        Your files have already been uploaded and they're sitting on your server under temp names found in e.fileArray[i].tempFileUploadedData. What do you want do to with them?

        Comment


        • #5
          Re: Xbasic function savefile not working

          My goal is to save them to this location "[PathAlias.ADB_Path]\myuploads"

          Comment


          • #6
            Re: Xbasic function savefile not working

            Ok I was over thinking it. Just wanted to say I have it working now. My Xbasic may not be clean but it works :)

            Code:
            function saveFile as v (e as p)
            dim fn as c
            dim tempfile as c
            dim i as n
            dim fntostore as c
            dim arr as p
            dim data as c	
            dim fntostore as c
            
            count= e.filecount 
            arr = e.filearray
            tempfile = e.fileArray[1].tempFileUploadedData
            
            tbl = table.open("[PathAlias.ADB_Path]\myuploads",FILE_RW_SHARED)
            
            for i = 1 to count	
            
            data = e.fileArray[i].fileName
            
            fn = "C:\A5Webroot\myuploads" + chr(92) + e.filearray[i].fileName
            
            file.copy(tempfile,fn)
            
            fntostore = e.fileArray[i].filename
            
            	tbl.enter_begin()
            	
            		tbl.ponumbers = e.primarykeyArray[1]
            		tbl.linkedfilename = fntoStore
            	tbl.enter_end()
            			
            
            next i 
            e.javescript = "window.parent.{grid.object}.refresh();"
            end function

            Thanks
            Last edited by jtm311; 11-29-2015, 10:10 AM.

            Comment


            • #7
              Re: Xbasic function savefile not working

              Yes... that's it John... I knew you'd get there once you understood that Alpha was auto-uploading the files to a specific location. I looked for a setting somewhere to specify that location, but I couldn't find one. Nicely done.

              Comment


              • #8
                Re: Xbasic function savefile not working

                Originally posted by Davidk View Post
                Yes... that's it John... I knew you'd get there once you understood that Alpha was auto-uploading the files to a specific location. I looked for a setting somewhere to specify that location, but I couldn't find one. Nicely done.

                Thank you for the help!

                Comment


                • #9
                  Re: Xbasic function savefile not working

                  I spoke to soon. I have a problem with mutable file uploads. The table is listing the correct file names and the location on the server is showing all the files with the correct names, however when opening each document they are just duplicates of the first file uploaded.

                  I also think I can get rid of the line in the code called data ?

                  Thanks
                  John

                  Comment


                  • #10
                    Re: Xbasic function savefile not working

                    If anyone is following here is the corrected code which now works.

                    Code:
                    function saveFile as v (e as p)
                    	
                    dim fn as c
                    dim tempfile as c
                    dim i as n
                    dim arr as p
                    
                    count= e.filecount 
                    arr = e.filearray
                    
                    for i = 1 to count	
                    
                    tempfile = e.fileArray[i].tempFileUploadedData	
                    fn = "C:\A5Webroot\docsupload" + chr(92) + e.filearray[i].fileName	
                    
                    file.copy(tempfile,fn)
                    
                    dim fntostore as c
                    
                    tbl = table.open("[PathAlias.ADB_Path]\docsupload",FILE_RW_SHARED)
                    
                    fntostore = e.fileArray[i].filename
                    
                    	tbl.enter_begin()
                    	
                    		tbl.refnumber = e.primarykeyArray[1]
                    		tbl.linkedfilename = fntoStore
                    	tbl.enter_end()
                    
                    
                    next i 
                    e.javescript = "window.parent.{grid.object}.refresh();"
                    end function

                    Comment

                    Working...
                    X