Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

    All
    I have a UX component, which has about 20 controls in it, almost all are textboxes.
    The primary purpose of the UX is to add new records into a matching table and to update them once in a while
    There is one list control in the component as well

    I had this setup and working fine...until..... I added a column to the table.

    after adding the column to the table:
    I refreshed the table information after editing the table schema in the UX
    I added a text box control to the UX for that table.
    I bound it to the table just like all of the other controls
    This field has a lookup to another table in the database (As do many of the other 19 fields that are working)
    PROBLEM: I can't get the UX to update the table.

    Symptoms:

    The field / record does not get dirty when you enter any data in the new field then move to another field
    If add or change values in another field of the same record I can then submit the record but the field in question does not update
    this can be seen in one of the attached images.

    What I tried

    I tried removing all the Data Binding Settings and redoing them - no luck
    I tried adding a second field to the database with a different name and going through the steps again no luck
    I changed the lookup to delete the dynamic filter (I do have another control with dynamic filter and that works) - No luck
    I changed the lookup to get rid of a stored value is different than display value - no change
    I have tried Live preview and working preview - no luck
    I at the point where I am just going to try to recreate the UX from scatch.
    I worked on this for about 5 hours yesterday searching the message board, and wiki

    A possible related or causual issue
    At some point after I had created the working version of the UX, I began to get "Array Index out of bounds" error messages when I clicked on the table-alias box in the data binding area of the properties for the suspect field (and others too)
    I can't remember if this happened before I added the field or after.
    That error is not popping up now.

    I am running version 12.3 build 2999

    I can attach more information if you can tell me what you need.

    Thanks to anyone who can help.

    Kevin Callanan

    UX component in working preview.pngUX Component Layout.pngUX component update notes.png

  • #2
    Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

    It's really tough to know what's going on without reviewing the component. Can you zip together the component and a dump of the table? The table doesn't need to have your real data... just a few fake records. Attach the UX and table dump here and I'll have a look.

    Comment


    • #3
      Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

      Also, is it possible to update to the latest version? Lots of development and fixes since 2999.

      Comment


      • #4
        Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

        I could have been more complete about my version number it is 2999 build 4519

        Comment


        • #5
          Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

          You might want to try downloading the latest prerelease. Those array out of bounds sounds like some errors in Alpha that could have corrupted the UX. You also could try recalculating the controls and see if that helps. And as Davidk said above...post a sample for someone to have a look.

          Comment


          • #6
            Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

            Ok, so I am going to take a stab at this since I consider myself king of random mistakes and or mis-steps.

            First of all, do ANY of the fields in your table have a space in the field name??? - if so get rid of it and watch your issue fade away.
            For Example: First Name vs First_Name
            a field such as the first will eventually cause a nightmare!

            Second, make sure that you actually have matching field "types" in other words N vs C
            I am almost certain Alpha will throw an error, but...

            Last of all, be aware that there certainly could have been an issue with dropdown boxes and lookups with your version as I recall that there were certain pre-release builds with issue so if you cannot figure it out - send in a bug report request specifically for your version. It may be that they made note of it in a subsequent fix. My only concern would be that you may be asked to upgrade in order to fix the problem, since there cannot be a warranty on pre-release builds, and frankly I am not sure where you're at with that version and number.

            So in short I would do a quick check for spaces in the field names...they play hell.
            NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

            Comment


            • #7
              Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

              David, Ken and Chris
              Thank you for your replies.
              I do check everyday to see if I have the latest version, However that apparently doesn't include patches which must be applied separately
              I applied all the patches yesterday.
              I can't really say if that solved the issue or not. I was pressed for time and because one of you mentioned that the UX might be corrupted, I simply went ahead and recreated it from scratch.
              This gave me some additional practice in creating the UX and I'm getting faster at it. It is a testament to AA that I can do this so quickly

              I will say the videos were a great help in getting the UX to do what I want should be looked at by anyone needing help with the UX, I had to watch 5 of them to get all the features I need. There are alot of steps and the videos lay them out pretty well
              I also have the Liberty Manuals and they too are a big help.

              Thanks for the offers to review my component and database, however at this point my issue is solved and my guess is you all have bigger fish to fry so let's consider this issue solved.

              Thanks again

              Kevin

              Comment


              • #8
                Re: UX fields not updating tables after adding column to database - possibly related to "Array Index out of Bounds" error?

                Kevin, glad you got your issues resolved. Once you get the hang of it, it goes fairly fast; but it is a learning curve, however I don't think more than anything else that abstracts functionality so the developer can focus on higher level code.

                Comment

                Working...
                X