Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Fatal error running a5_ajax_grid() after updating to the AAv4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error running a5_ajax_grid() after updating to the AAv4

    Hi All...

    Trying to figure out what is going here...after updating to the AAv4 (not 4.1) all users are getting:

    Fatal error running a5_ajax_grid(): Result stack data overflow on line 25 in 100139d:pl

    when clicking a button that links one grid to another.

    The odd part is I don't get the error when testing with Alpha Developer so I'm not sure where to start with TS this...

    Any ideas/suggestions?

    Thanks
    Joe
    Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

  • #2
    Re: Fatal error running a5_ajax_grid() after updating to the AAv4

    Is the server updated?

    Comment


    • #3
      Re: Fatal error running a5_ajax_grid() after updating to the AAv4

      Yes, I'm patching to 4.1 right now. Just in case something was fixed from 4 to 4.1...will update shortly
      Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

      Comment


      • #4
        Re: Fatal error running a5_ajax_grid() after updating to the AAv4

        No change with patching to v4.1
        Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

        Comment


        • #5
          Re: Fatal error running a5_ajax_grid() after updating to the AAv4

          To be sure, you've also updated your development environment? I always make sure I publish something when I upgrade like this.

          Is this error on one particular component? When/where does it occur? If one, edit it, make it dirty in any way at all, save and republish it.
          -Steve
          sigpic

          Comment


          • #6
            Re: Fatal error running a5_ajax_grid() after updating to the AAv4

            Dev is running Version 12.4.1 Build 3583 Build 4662 and the App Server is Build 3583-4662. If I do check for new version on both it says they are the most current version.

            I believe it is one component (limits18). I've edited the component and republished it but no luck.

            ARC 05-09-16 Transact and Limits.zip
            Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

            Comment


            • #7
              Re: Fatal error running a5_ajax_grid() after updating to the AAv4

              So now this really doesn't make any sense...I started a second instance of the application server on the same server that it is currently running on. Configured it to use a different port and setup a different directory to publish to. Published the whole application and it works.

              So...I figured...hmmm...let me publish the app to the production directory but choose "All files in the project" and uncheck the box "Publish new or modified files only"....

              No difference...yet I can go to the other instance of the application server and it works...it's the same published files...

              so confused...
              Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

              Comment


              • #8
                Re: Fatal error running a5_ajax_grid() after updating to the AAv4

                So the plot thickens...some records get the error others do not....all worked prior to the update.
                Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                Comment


                • #9
                  Re: Fatal error running a5_ajax_grid() after updating to the AAv4

                  I've now tested multiple browsers for the same record to see if that had something to do with it and it didn't help. The odd part is I can access the record on my machine but the user who needs to access it gets the Data Stack Overflow error. Same network...no firewalls between the user and the app server (all internal).

                  Very frustrating...
                  Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                  Comment


                  • #10
                    Re: Fatal error running a5_ajax_grid() after updating to the AAv4

                    So we are seeing a weird conflict issue as well...it may or may not be related to this error but I'm thinking it is something to do with how Alpha works with MariadB. No proof yet...just a hunch.
                    Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                    Comment


                    • #11
                      Re: Fatal error running a5_ajax_grid() after updating to the AAv4

                      Try rolling back to 4650 on the appserver and see if that works, I have had an issue which seems to have gone away by rolling back. I am just trying to determine if it is an issue or if the update has exposed a flaw in a component/report.
                      Glen Schild



                      My Blog

                      Comment


                      • #12
                        Re: Fatal error running a5_ajax_grid() after updating to the AAv4

                        Thanks Glen for the reply....I thought about that but I thought that my components won't work if I do that. I'm guessing I'm wrong on that?
                        Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                        Comment


                        • #13
                          Re: Fatal error running a5_ajax_grid() after updating to the AAv4

                          The changes since 4650 are minimal so I have not experienced an issue in that regard.
                          Glen Schild



                          My Blog

                          Comment

                          Working...
                          X