Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

convert_Number() line:25 --- Where to find the SCRIPT so I can look at line 25 for clues?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CarlMPearson
    replied
    Re: convert_Number() line:25 --- Where to find the SCRIPT so I can look at line 25 for clues?

    I had move forward to each of the later releases, but the later versions had an OnChange and OnBlur event bug that rocked a different UX.

    I republished with updated developer versions, doing a complete rebuild.
    It is so damned intermittent, only hits a row here or there, and the data in those rows are pristine.

    Timing? Browser? OS fix level?
    If it would happen every time, I could find it and/or workaround.

    I have two servers, current and production, to avoid the "back level" gotcha.

    It hadn't happened in a few weeks and today a customer had it happen on one specific row, across three different users.
    But I went there, same web site, and got right in. Browser caching? Clear history? Company proxy? Dunno.

    And so it goes ....................................

    Leave a comment:


  • mikeallenbrown
    replied
    Re: convert_Number() line:25 --- Where to find the SCRIPT so I can look at line 25 for clues?

    Must you stay on 4668? ... you're two official builds behind. Latest build is 4684. If you can I'd update to this one and try again. There very well may have been a bug that Alpha fixed.

    Leave a comment:


  • CarlMPearson
    replied
    Re: convert_Number() line:25 --- Where to find the SCRIPT so I can look at line 25 for clues?

    I have current Chrome as browser and do not get this error. Yet customers get this error.

    I can go to same exact record without issue. I've been hunting this one for months.

    I think it is a browser issue, but somehow the browser irritates the server into sending this response.

    Grrrr.
    Last edited by CarlMPearson; 08-12-2016, 12:08 PM.

    Leave a comment:


  • convert_Number() line:25 --- Where to find the SCRIPT so I can look at line 25 for clues?

    Developer and WAServer are at same level. 4668.

    It results in an error when opening up a detail grid. grid_Locations is the grid.

    It only errs on a small number of rows, and there is nothing odd looking in the data.

    BTW, the grid has been running for 6 months, and I re-published the grid after updating the server 6 weeks ago.

    No problem, just started recently. If I can find the SCRIPT line 25, I might get a clue from that. Or Line 62.

    ================================================================
    From the error log: I get 6 of these all at once with the same error: Script:convert_Number() line:25


    Fri Jul 08 15:11:58 2016


    Thread: AppServerWorker19
    Request URI: /UCO/__a5RunGrid.a5w?__pageName=__a5runGrid.a5w&__gridFilename=grid_Locations&__alias=TBI_GRID_LOCAT_44742EQBK&__unsaved=no&_isLookupGrid=false
    Script: " /UCO/__a5RunGrid.a5w"
    Line: 62
    x_out = a5_ajax_grid(tmpl)
    Script:convert_Number() line:25
    Result stack data overflow
    Execution Stack:
    0#1 evaluate_shared_private(
    0#37 OOhttpdServerClientMIME(ptemp,"AppServerMain")
    0#2 A5WCallResult = evaluate_a5w_to_response(page_contents,Response,quote(" " + eval_settings.global.Request.ScriptName),eval_settings,EVALUATE_A5W_TIMEOUT,RequestBundle.RequestInfo.Filename.Path)
    0#62 x_out = a5_ajax_grid(tmpl)
Working...
X