Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Problem with cloning a record

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with cloning a record

    I am using {dialog.object}.newRecord({cloneExisting: true}) to duplicate a record in a web component connected to a MySQL database. It works great, except for a large text field that usually contains line breaks. In that case, the duplicated record only shows "<<%str%" in that field. If there's only one line of data with no line breaks, the field is cloned properly. How can I get this field to always copy correctly?

    Nathan

  • #2
    Re: Problem with cloning a record

    Originally posted by Nathan Zeiset View Post
    I am using {dialog.object}.newRecord({cloneExisting: true}) to duplicate a record in a web component connected to a MySQL database. It works great, except for a large text field that usually contains line breaks. In that case, the duplicated record only shows "<<%str%" in that field. If there's only one line of data with no line breaks, the field is cloned properly. How can I get this field to always copy correctly?

    Nathan
    Hi Nathan,

    Can you post a component that exhibits this behavior?
    Sarah Mitchell
    Documentation | Alpha Software Corporation
    Get in the know! Join us for our Weekly Webinars: TransForm Tuesday and Wednesday's Alpha Anywhere Demo and Q&A
    Connect with us: Instagram | Twitter | Facebook | LinkedIn | YouTube

    Comment


    • #3
      Re: Problem with cloning a record

      Hello Beta,

      I have attached a test component that exhibits this behavior when you click on the "Save as New" button if the Summary field has a line break in it.

      Thanks!
      Nathan
      Attached Files

      Comment


      • #4
        Re: Problem with cloning a record

        Originally posted by Nathan Zeiset View Post
        Hello Beta,

        I have attached a test component that exhibits this behavior when you click on the "Save as New" button if the Summary field has a line break in it.

        Thanks!
        Nathan
        Hi Nathan,

        Do you have a sample of your database used by this component that you could upload as well? If you don't want to share real data from your DB, a small sample of each table with a few example records is more than sufficient - provided the data can be used to reproduce the behavior.

        Thanks
        Sarah Mitchell
        Documentation | Alpha Software Corporation
        Get in the know! Join us for our Weekly Webinars: TransForm Tuesday and Wednesday's Alpha Anywhere Demo and Q&A
        Connect with us: Instagram | Twitter | Facebook | LinkedIn | YouTube

        Comment


        • #5
          Re: Problem with cloning a record

          Sorry to take so long to get this done. It's been a busy week.

          I have attached a zip file that contains both an updated component and the data file. If you click on "Save as New" for the first record, it works fine since the summary field only has one line of text, but when you do that for the second record, the summary field, which has two lines of text, shows the behavior I described earlier.

          Thanks!
          Nathan
          Attached Files

          Comment

          Working...
          X